User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Lots of warning lights + loss of power steering

  1. #1
    Regular Member Sparky67's Avatar
    Join Date
    Dec 2009
    Location
    West Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Lots of warning lights + loss of power steering

    The battery light has been coming on recently after a few miles. Last night it came on again, followed by the radio cutting out, the power steering light and a loss of power steering, then the ABS light, then the seatbelt light and finally the spanner light... Just got home and can't start it this morning - battery nearly flat. It's an 07-plate CDTi 150.

    Checked the drive belt and it looks ok and seems tight enough. Any thoughts on what else to check / what it could be pse ?

  2. #2
    Regular Member Lao's Avatar
    Join Date
    Aug 2009
    Location
    Romania, E.U.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate Automatic

    Trim : Elegance

    Engine : Z19DTH

    Year : 2005

    Default

    Your alternator just got busted.

  3. #3
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Check the voltage at the battery with the car running.

  4. #4
    Regular Member murf2484's Avatar
    Join Date
    Apr 2006
    Location
    normanton west yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    possibly the alternator it did that when mine went the battery has all the power drained so hense all the failures to the systems

  5. #5
    Regular Member Sparky67's Avatar
    Join Date
    Dec 2009
    Location
    West Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks guys. Charged the battery for a couple of hours and got it started. Across the battery straight after starting is 11.7V with the engine running, which seems a bit on the low side...?

  6. #6
    Vectra-sport Admin Dre's Avatar
    Join Date
    Dec 2009
    Location
    Vectra-sport Admin
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXD




    Default

    Same happened to me last year its the alternator vxl do refurbished ones on exchange and they come with a 12mth warranty be mindful of the cheap ones on the bay can-bus can through a fit with them

  7. #7
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    As the others have said bud your alternator is goosed the voltage should be around 14v me and Antsss have done a few now all the same symptom as yours
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  8. #8
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Quote Originally Posted by Sparky67 View Post
    Thanks guys. Charged the battery for a couple of hours and got it started. Across the battery straight after starting is 11.7V with the engine running, which seems a bit on the low side...?
    Running it should be about 14.4v

  9. #9
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As the guys have said its the alternator.

  10. #10
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    41 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    As all above 110% alternator
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  3. Loss of power steering
    By scrivy in forum Engine & Drivetrain
    Replies: 5
    Last Post: 25th June 2012, 21:08
  4. Spanner warning light and loss of power!
    By mishima in forum Vectra C / Signum Troubleshooting
    Replies: 12
    Last Post: 16th October 2009, 20:18
  5. Sudden loss of power - No warning Lights.
    By signum_1.9 in forum Engine & Drivetrain
    Replies: 45
    Last Post: 9th February 2009, 13:43

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •