User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Just cleaned the boost sensor of my cdti 150 and ....

  1. #1
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Smile Just cleaned the boost sensor of my cdti 150 and ....

    It was filthy and caked and blocked with baked on carbon build up. Car was running great before I did it but thought i'd give it a go. Its now gleaming clean. I can honsetly say I notice no difference whatsoever. The car still running great. Testiment to these little devices how they perform when totally gunged up.

  2. #2
    Regular Member
    Join Date
    Apr 2011
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i was getting excited here hoping you were gonna tell everyone that cleaning this made a massive difference lol wat a let dwn

    like u say credit if the we part is battling away after being clogged up!

  3. #3
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi 150 Hatch

    Trim : SRi

    Engine : Z19DTH

    Year : 2008

    Mileage : 69'000

    Default

    exactly the same as me, I cleaned the egr and boost sensor over the last few weeks and its made no difference to the running or performance, not like I had a problem in the first place but least they are all nice and clean now and shouldn't need cleaning to often with the fiat egr plate fitted.

  4. #4
    Regular Member Barlow's Avatar
    Join Date
    Jan 2012
    Location
    Chester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan 350Z GT


    Engine : 3.5 V6

    Year : 06

    Mileage : 50,000

    Default

    Mine actually ran worse lol

  5. #5
    Regular Member bigdave1701's Avatar
    Join Date
    Apr 2010
    Location
    York
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I think things like the boost sensor have to be really really ******ed before you notice much of a difference from cleaning.

  6. #6
    Regular Member
    Join Date
    Aug 2010
    Location
    Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well I cleaned my EGR and boost sensor about 6 weeks ago and it made loads of difference. Now I think I'm going to take a look at the boost sensor again, performance has dropped.


    Mick

  7. #7
    Regular Member farley2708's Avatar
    Join Date
    Apr 2010
    Location
    antrim n.ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Talking

    When i first cleaned mine it was bad,cleaned it with carb cleaner,cotton swabs up inside,done the airbox mod,changed the vac pipes & cleaned the EGR.....................boy did it make a difference,was like wooooo where did all the power come from

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. One cleaned Boost Sensor......
    By signum_1.9 in forum Engine & Drivetrain
    Replies: 20
    Last Post: 20th August 2012, 00:22
  2. please help, eml still onl, cleaned boost sensor and egr
    By J P S in forum Engine & Drivetrain
    Replies: 1
    Last Post: 31st May 2012, 12:25
  3. Just cleaned my boost sensor
    By bigdave1701 in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 30th July 2011, 19:43
  4. Just cleaned my egr and boost sensor !!
    By renton608 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 17th January 2011, 17:32
  5. cleaned boost sensor and still shows over boost
    By chowwie in forum Engine & Drivetrain
    Replies: 2
    Last Post: 14th November 2008, 09:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •