User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: instrument light fuse ?

  1. #1
    Regular Member neilb1's Avatar
    Join Date
    Feb 2011
    Location
    wigan
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default instrument light fuse ?

    Anyone know the fuse for the instrument lighting all the clock lightening is out and not working rev, speedo and petrol gauge
    vectra c as well
    Last edited by neilb1; 16th March 2012 at 21:49.

  2. #2
    Regular Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    Sounds more like a faulty CIM..

  3. #3
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It does sound like a faulty cim, but check fuse 12 in dash fusebox.

  4. #4
    Regular Member neilb1's Avatar
    Join Date
    Feb 2011
    Location
    wigan
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    whats a cim ?

  5. #5
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It's the control unit on the steering column that controls dash lights, speedo, rev counter and fuel/temp gauges.

  6. #6
    Regular Member mcpitman's Avatar
    Join Date
    May 2011
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Club

    Engine : 1.9 CDTi

    Year : 2004

    Default

    Could also be the dash clock assembly itself, mine went that way, cim is fine...

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Or even the ABS plug if your cars in the right age group and a 54 plate fits it perfectly, mind you so does a faulty CIM Check THIS out mate.

  8. #8
    Regular Member
    Join Date
    May 2006
    Location
    North Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I think mine has the same symptons - when I put key in only engine light onfar right is light. Engine starts and the light goes out. |Then no lights on dashboard and no speedo, fuel revs etc. Indicators and lights work ok. Has your problem been solved with a fuse (hoping!).

  9. #9
    Regular Member mcpitman's Avatar
    Join Date
    May 2011
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Club

    Engine : 1.9 CDTi

    Year : 2004

    Default

    Quote Originally Posted by Mike57 View Post
    I think mine has the same symptons - when I put key in only engine light onfar right is light. Engine starts and the light goes out. |Then no lights on dashboard and no speedo, fuel revs etc. Indicators and lights work ok. Has your problem been solved with a fuse (hoping!).

    Exactly the same symptoms as mine, search for a thread called "dashboard is kapput"

    Mine wasn't the cim or any fuses, just the dash irself that had died....

  10. #10
    Regular Member
    Join Date
    May 2006
    Location
    North Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Found a useful thread with helpful fuse numbers from Robsey. I removed and put back fuses 17, 26 and 10 from the passenger side fusebox, and all is well!! I am not sure which one did the trick, but it saved me an expensive trip tto the dealers. I hope this will solve your problerm as well, neilb1. For info, my clock/temp was working, and pulling out 1 of the three fuses above reset the clock.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What fuse for interion light?
    By amd in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 25th August 2011, 00:00
  2. URGENT:Glovebox Light/Interior Light Fuse
    By Hendry in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 5th June 2011, 09:13
  3. B1454 (AFL) and B2652 (Instrument light)
    By fikse in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 26th April 2011, 12:13
  4. Parkpilot Instrument Light, Tech 2 help needed
    By tramman in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 7th April 2010, 20:35
  5. Boot light - Where is the fuse?
    By Schui1024 in forum Electrical & ICE (including SatNav)
    Replies: 18
    Last Post: 23rd March 2010, 01:04

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •