User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Swirl linkage advice please?

  1. #1
    Regular Member Gerdo3's Avatar
    Join Date
    Mar 2009
    Location
    Blantyre
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Swirl linkage advice please?

    got my mate to do the b&q repair to the linkage but when he connected up it came up with a fault code, when he investigated it turns out that the no 4 pod swirl flap is flapping about and is feked, thinks this is due to oil residue blowing up and thru this, everyother one is fine, but he had no choice other than to disconnect it so that car came off limp mode, my question is will I now need a new manifold, or is their a work round this

    cheers
    Gery

  2. #2
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Usually if the repair is done right & when started & revved the bar moves freely it should be ok, but sometimes if the repair is a tight fitting & hinders /restricts the movement of the motor & bar it can throw a fault light & limp mode,

  3. #3
    Regular Member Gerdo3's Avatar
    Join Date
    Mar 2009
    Location
    Blantyre
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    apparently number 3 is the one which controls the bar and the others and is working fine

  4. #4
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    First thing i would do is to check and clean your EGR valve if you havnt already,if its clogged/blocked then the pressure will build up in the manafold and the exhaust gasses will find the weakest place to escape through(the plastic swirl pots)

    My 4th swirl pot started off leaking and over the space of a couple of months they have all gone the same way(apart from pot number 3 which is attached to the motor) they are all leaking aswell as having 3-4mm vertical movement so i know that the manafold is loosing pressure.My bar came off and although it does stay on for a day or so i have just left it off as the car is running fine apart from a small drop in performance but because im getting very good MPG im leaving it alone......for now.

    There is a guy on here who had the same problem and actually sealed his swirl pots in the "open" position(10 o'clock position as you look down at the pots) with liquid metal and the car runs perfect.It makes sence if you think about it as not only does it meen the gasses are free to escape via the right route but also the manafold will be air tight so no loss in pressure(which i think effect boost pressure)

    I will be doing this myself in the summer when the weather gets better.

  5. #5
    Regular Member Gerdo3's Avatar
    Join Date
    Mar 2009
    Location
    Blantyre
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by justin32 View Post
    First thing i would do is to check and clean your EGR valve if you havnt already,if its clogged/blocked then the pressure will build up in the manafold and the exhaust gasses will find the weakest place to escape through(the plastic swirl pots)

    My 4th swirl pot started off leaking and over the space of a couple of months they have all gone the same way(apart from pot number 3 which is attached to the motor) they are all leaking aswell as having 3-4mm vertical movement so i know that the manafold is loosing pressure.My bar came off and although it does stay on for a day or so i have just left it off as the car is running fine apart from a small drop in performance but because im getting very good MPG im leaving it alone......for now.

    There is a guy on here who had the same problem and actually sealed his swirl pots in the "open" position(10 o'clock position as you look down at the pots) with liquid metal and the car runs perfect.It makes sence if you think about it as not only does it meen the gasses are free to escape via the right route but also the manafold will be air tight so no loss in pressure(which i think effect boost pressure)

    I will be doing this myself in the summer when the weather gets better.
    Thanks Justin, EGR valve is ok new one fitted last summer, spoke to me mate and he said that will work no problem, (he is annoyed he never thought of that) so he will be doing mine on saturday and will get car back on sunday and will let you know

    cheers mate

    pps saw another discussion re blanking off egr valve? worth doing?

  6. #6
    Regular Member Gerdo3's Avatar
    Join Date
    Mar 2009
    Location
    Blantyre
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Justin

    my mate did no 4 pot and car has got mid range urgency back that was missing, been running for 10 days now and no issues, warning lights etc, so my mate is now going to do the other pots as well (now that there have been no problems)
    will let you know when its done
    cheers

  7. #7
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I super glued my pots (1,2 & 4) open at the weekend. Runs just fine and although number 3 is leaking some pressure, with all the other swirl valves in the open position, most fumes appear to be being sucked into the engine instead of diffusing into the engine compartment and then into the cabin. Wished I had ripped the rod off ages ago and gleued them.

  8. #8
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default



    Done mine too.

    If #3 is leaking, remove the link from the motor to the swirl, and glue that one too. Put plenty of glue around it to seal the leak

    This leaves the motor to turn as needed, and prevent any faults being chucked up

    I've glued 1,2,4, letting 3 run with the motor. 12k miles now and no issues.

  9. #9
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quite a few of us have now done plenty of mileage with pots 1,2 & 4 bonded in the open position... well worth doing imo

  10. #10
    Regular Member R-man's Avatar
    Join Date
    Aug 2005
    Location
    Beds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    is there a How 2 on this jobbie?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Swirl flaps Linkage Rod
    By AntSSSS in forum Vectra C / Signum Car Chat
    Replies: 203
    Last Post: 3rd August 2010, 21:46
  2. Swirl Rod Linkage
    By bafoo in forum Troubleshooting
    Replies: 6
    Last Post: 9th July 2010, 16:26
  3. EML was on now off...could it be swirl valve linkage
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 23rd March 2010, 09:14
  4. Swirl flap linkage fallen off but managed to bodge it! (I hope!)
    By jrwilshire2003 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 22nd January 2010, 22:42
  5. Swirl Flap Linkage Rod 'Cheap' Fix
    By AntSSSS in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 1st April 2009, 20:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •