User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Vectra Z18XER Poor Running

  1. #1
    New Member
    Join Date
    Dec 2011
    Location
    Home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra Z18XER Poor Running

    My Vectra 2008 Z18XER seems OK when cold, but when is warmed up its not very happy.

    It hesitates under acceleration, very jerky under deceleration, idle is a little erratic and MPG has dropped (although I have had to push it harder)

    Any ideas? A mate suggested an EGR valve issue, another said it didn't have one!! Help!

  2. #2
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Yea the vvt doesnt have an EGR. More likey to be the MAF on its way out or a dodgy coil pack or plugs. Could also be the solenoid filter for the vvt system, a couple seen this issue lately with the vvt.

  3. #3
    New Member
    Join Date
    Dec 2011
    Location
    Home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by DasArab View Post
    Yea the vvt doesnt have an EGR. More likey to be the MAF on its way out or a dodgy coil pack or plugs. Could also be the solenoid filter for the vvt system, a couple seen this issue lately with the vvt.
    Thanks for that, it feels very similar to the time my HT leads needed replacing on my Cavalier especially as it seems to get worse the hotter the engine bay becomes - in traffic for example, so the coil pack could well be the answer.

    Looks like it will need checking out at the dealer then!

    Cheers, MX

  4. #4
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    LoL, yea I know what you mean, used to have to replace them on my cavi's on a yearly basis.

  5. #5
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    Check the CTS

  6. #6
    New Member
    Join Date
    Dec 2011
    Location
    Home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by troutybrown View Post
    Check the CTS
    Not sure what the CTS is TBH!

    Coolant Temp Sensor??

  7. #7
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    Quote Originally Posted by mxspyder View Post
    Not sure what the CTS is TBH!

    Coolant Temp Sensor??

    Yep

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Z18XER Burnt valves replaced/ still not running right
    By aeu9921 in forum Engine & Drivetrain
    Replies: 17
    Last Post: 5th February 2013, 22:08
  2. Engine cut out and poor running, Z22SE
    By Butler in forum Engine & Drivetrain
    Replies: 9
    Last Post: 10th February 2012, 20:48
  3. 2.2 direct serious judder/poor running!help!
    By leem82 in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 9th October 2010, 10:59
  4. car wont start and poor running help pls
    By winnie2457 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 3rd January 2010, 21:16
  5. 1.8 Poor running - Help!!
    By abbeytec in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 18th September 2008, 19:29

Visitors found this page by searching for:

does vectra z18xer have an egr valve

z18xer poor running

does the vectra c z18xer have a egr valve

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •