User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Think I killed my vectra need help

  1. #1
    Regular Member
    Join Date
    Dec 2011
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy Think I killed my vectra need help

    Ok so got 2.2 dti with occasional boost and egr faults. Today I removed the manifold top cover and took egr off. Cleaned it up nicely. Also replaced all vac pipes again. Refitted everything. Started car and got a horrible clattering. Bit like a bad diesel knock. Stopped engine. Thought for a minute. Tried to restart but now engine will not start. No faults in any systems. Tried and tried to start but just won't. I have a really bad feeling I have knocked loose lots of carbon build up into inlet as did not completely remove and it does look badly coked up. When it did start it sounded awfull and that's why I stopped it quickly. But whatever I done I think it's done it's damage. Really not sure what to do now. I didn't touch fuel pipes so cant see it would be an issue with air. Any one any ideas what to do?
    Last edited by paulhb; 22nd March 2012 at 21:14.

  2. #2
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    Might be carbon sticking the valves open you could remove everything again and check or start it and boost it to let it clear

  3. #3
    Regular Member
    Join Date
    Dec 2011
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It refuses to start now. Sounds almost like there is no compression. Checking valves would be head off right?

  4. #4
    Regular Member Mopar Man's Avatar
    Join Date
    Jan 2011
    Location
    herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Up to you, but i would tow start it. It will go eventually.

  5. #5
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    No compession means possibly just the carbon you have moved has stuck valves open, keep cranking or drag it normally. Just advise though as not there can't be 100%

  6. #6
    Regular Member
    Join Date
    Dec 2011
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Tried to tow start it and no joy. Gave it a few goes and broke a rope lol. But on a serious note not a tick from the engine. When it turns it just sounds dry and dead.

  7. #7
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Easy start bud,spray it into the air intake,

  8. #8
    Regular Member Toe-side's Avatar
    Join Date
    Dec 2011
    Location
    Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Injector Return pipes perished???? Should start after tow though had to replace mine twice with the old 2.2

  9. #9
    Regular Member
    Join Date
    Dec 2011
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    all injector return pipes look ok - no visible signs of any leaks - assuming they would leak if perished? or would there be a chance there just sucking in air? do they just push fit in? what i mean is i can see they go in just above the feed but cant see exactly how there fitted

  10. #10
    Regular Member Toe-side's Avatar
    Join Date
    Dec 2011
    Location
    Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If they are perished the draw air in. Had to replace two sets on my last veccy B just stopped starting but would only prime after a tow. Starter motor would not prime when cold .............a real ******. You should see small cracking on some of the return pipes near where they fit to the plastic tee pieces.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. holy christ My vectra killed itself please help explain!
    By IDVAC in forum Engine & Drivetrain
    Replies: 67
    Last Post: 15th March 2012, 20:56
  2. could have killed someone
    By jb-redbull in forum General Chat
    Replies: 31
    Last Post: 13th September 2010, 16:31
  3. Has your vec ever nearly killed you????
    By duncan2008 in forum Suspension, Wheels & Brakes
    Replies: 14
    Last Post: 18th April 2009, 15:06
  4. think i might of killed my vectra...
    By Rockster in forum General Chat
    Replies: 77
    Last Post: 22nd January 2009, 00:28
  5. I think I have just killed my car :(
    By v6diesel in forum Engine & Drivetrain
    Replies: 7
    Last Post: 11th December 2008, 00:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •