User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Y30DT - Occasional Spanner Light

  1. #1
    Regular Member wotsthestory's Avatar
    Join Date
    Jun 2007
    Location
    Carshalton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Y30DT - Occasional Spanner Light

    My Z32SE used to regularly light the spanner light and extinguish on a run, more often when you were cruising on the motorway, if you drove it like you stole it (which was all to tempting ) you never saw it. It was an ex-police car and though it drove fantastically it did have a few DTC's stored because of things they mucked about with, so I ignored it.

    Anyway I digress, my new car is doing this occasionally, usually after coming off a 50 limit dual carriageway on my way home. Stopping at the lights it sometimes it pops up, unlike the Z32SE it never disappears again until it's stopped restarted. No limp mode or anything, car performs exactly as before.

    When I got the car I downloaded the fault codes with OP-COM, the only recorded, but not currently logged was as below. I haven't checked this since, will do this weekend. I'm also waiting for it to come on when I'm in the car so I can plug in and get the information there and then.

    Car had a private garage service after the fault codes were checked above and I did a manual service indicator reset. Oil/Fuel/Air change etc.

    Related? Where is this sensor and does anyone have a part code?

    P0520 - Engine Oil Pressure Sensor/Switch Circuit Range/Performance
    (00) - Not present

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    The pressure switch would flash up an oil warning light not EML

    If its popping up after being at cruising speed I'd be saying something like a sticky egr valve.

    But have a read of codes and live data as it happens is really the only way a head or your finding a needle in a haystack

  3. #3
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    The pressure switch would flash up an oil warning light not EML

    If its popping up after being at cruising speed I'd be saying something like a sticky egr valve.

    But have a read of codes and live data as it happens is really the only way a head or your finding a needle in a haystack

  4. #4
    Regular Member
    Join Date
    Sep 2011
    Location
    Kent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    My oil level light comes on sometimes after a gentle long cruise up the motorway only done 3 times I think . Oil is ways about 2/3 full could that be egr ?

  5. #5
    Regular Member wotsthestory's Avatar
    Join Date
    Jun 2007
    Location
    Carshalton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Oil is different and the Z32SE used to use it a bit so was aware of that light. I'll check it all over tomorrow, I'll also do the position tests. Is it worth cleaning the EGR?

  6. #6
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Rob12 View Post
    My oil level light comes on sometimes after a gentle long cruise up the motorway only done 3 times I think . Oil is ways about 2/3 full could that be egr ?
    It could be a slightly dodgy pressure switch. Because the oil light is pressure not level.

    Quote Originally Posted by wotsthestory View Post
    Oil is different and the Z32SE used to use it a bit so was aware of that light. I'll check it all over tomorrow, I'll also do the position tests. Is it worth cleaning the EGR?
    You could try cleaning it. But its a fair bit of work to get to the y30dt egr valve

  7. #7
    Regular Member wotsthestory's Avatar
    Join Date
    Jun 2007
    Location
    Carshalton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Critch View Post
    It could be a slightly dodgy pressure switch. Because the oil light is pressure not level.
    Have you got that back to front? The fault code logged previously was pressure sensor. In my previous Vectra the oil light came on if the oil was low.

    Sorry a bit confused

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    That wasn't for you mate.

    But as far as I know the it's for pressure. It may well appear when oil is low aswell due to less oil therefore less pressure

  9. #9
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    That wasn't for you mate.

    But as far as I know the it's for pressure. It may well appear when oil is low aswell due to less oil therefore less pressure

  10. #10
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    If it is erratic, leave it providing it is not putting the engine into safe mode

    I suspect what is happening is one the two sensors is reaching the end of its life, but is still providing an oil pressure measurement from the other sensor
    Visit a garage with experience of the Y30DT engine and ask them to identify the two sensors for you
    Replace both of them when one of them fails (which will put the engine into safe mode)

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light reset emission light now on HELP!
    By johnny boy67 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 7th December 2009, 12:07

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •