User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Heater

  1. #1
    Regular Member
    Join Date
    Mar 2012
    Location
    gloucestershire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default Heater

    I have noticed the heater on my car isnt working on any of the settings from 1-7. I did hear a faint noise from the air vent but this soon stoped.
    Vauxhall told me it could be the electronic climate control regulator which costs £170.

    Anyone else had this problem. Anything i should check before i spend my cash. I have checked the fuses.

    2004 vectra gsi

  2. #2
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Is the fan spinning up? Have you checked the pollen filter to see if its blocked and the drainage channels next to the pollen filter, as you may have flooded the fan and caused it to short out? Is the front passenger carpet wet?

  3. #3
    Regular Member
    Join Date
    Mar 2012
    Location
    gloucestershire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Haven't had chance yet to check the fan or pollen filter.
    Will do this on my next day off. The carpet is dry. Was one of the first things I checked

  4. #4
    Regular Member
    Join Date
    Mar 2012
    Location
    gloucestershire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Haven't had chance yet to check the fan or pollen filter.
    Will do this on my next day off. The carpet is dry. Was one of the first things I checked

  5. #5
    Regular Member
    Join Date
    Mar 2012
    Location
    gloucestershire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quick update. I have managed to check the pollen filter and that was ok but the drainage hole was slightly blocked. Cleaned this out and all dry and clear. The fan is ok and the problem is down to the climate control regulator which is bolted to the bottom of the fan. Vauxhall wanted £213 in total.

    I have managed to find the same part for £90+£5 delivery.
    Will post pics of the damage part if anyone wants to see what they look like..

  6. #6
    Regular Member
    Join Date
    Mar 2012
    Location
    gloucestershire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Another update. The fan motor was also wet and damaged and needed to be taken out.
    Removed it and on testing got nothing. Few squirts with electrical contact cleaner and second test and it started to spin. Spent the next hour cleaning and makeing sure all traces of warter and gunk was gone.
    I now have a fully working heater in the car.
    Vauxhall can stick there £313+ asking price

  7. #7
    Regular Member
    Join Date
    Mar 2012
    Location
    gloucestershire
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Another update. The fan motor was also wet and damaged and needed to be taken out.
    Removed it and on testing got nothing. Few squirts with electrical contact cleaner and second test and it started to spin. Spent the next hour cleaning and makeing sure all traces of warter and gunk was gone.
    I now have a fully working heater in the car.
    Vauxhall can stick there £313+ asking price

  8. #8
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i had the same problem about a year ago
    i started a thread to warn people to clean their scuttle tray out regular
    mine was just the resister pack 20 pounds
    but people with climate control its a very dear game with the regulator
    glad you got it sorted out

    http://www.vectra-c.com/forum/showth...t=scuttle+tray

  9. #9
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by sparky1292 View Post
    Quick update. I have managed to check the pollen filter and that was ok but the drainage hole was slightly blocked. Cleaned this out and all dry and clear. The fan is ok and the problem is down to the climate control regulator which is bolted to the bottom of the fan. Vauxhall wanted £213 in total.

    I have managed to find the same part for £90+£5 delivery.
    Will post pics of the damage part if anyone wants to see what they look like..
    I would really appreciate pic's matey... I have ECC & my fan stopped working this morning, everything else works IE: the control panel, air direction etc... i have checked all fuses, scuttle tray is never blocked as i have been checking on a weekly basis for years, pollen filter is bone dry & only a couple of months old, i can spin the fan from the top although i haven't taken the glove box out yet so any pic's or links to a cheaper than VX part will be great

  10. #10
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    has anyone else resolved the failing motor issue on a motor with ECC?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. no hot air out of heater. please help!!!
    By jonny22 in forum Troubleshooting
    Replies: 9
    Last Post: 18th November 2012, 14:22
  2. Heater fan
    By ibbo in forum Bodywork & Interior
    Replies: 0
    Last Post: 22nd September 2011, 20:19
  3. heater
    By keith_johnson1967 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 14th February 2011, 22:30
  4. heater is on way out i think
    By dan1983 in forum Bodywork & Interior
    Replies: 3
    Last Post: 30th January 2010, 13:53
  5. pre-heater
    By andrew m in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 31st October 2008, 21:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •