User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Faulty MAF or turbo?

  1. #1
    Regular Member krazylegz's Avatar
    Join Date
    Dec 2009
    Location
    South Shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Faulty MAF or turbo?

    My vectra c 2.2 dti is still going into limp mode when put under load.

    I've tried changing all the vacuum solenoids, checked all vac pipes, changed turbo actuator, new boost sensor

    Went to the scrappy yesterday and got another egr valve and MAF as it was showing up P0400 code in opcom and something about boost.

    So I put both on, however it's not the correct MAF as its a different number, anyways with both on the spanner light never came on but it seemed as if there was no turbo at all as it couldn't pull the skin off a rice pudding, so tried the old MAF back on today and it seemed a bit better at pulling but back to the spanner light and limp mode coming on.... The car itself feels very very under powered and wondering of the turbo itself could be at fault?

  2. #2
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    What type/model turbo is it Lee? If it hss an internal wastegate the diapraghm may be split as that can cause such syptoms.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  3. #3
    Regular Member krazylegz's Avatar
    Join Date
    Dec 2009
    Location
    South Shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have no idea nige lol..... It's a garret that's all I know lol. I'll have a look on it tomorrow for any numbers etc. I've heard somebody else mention that tbh, just seems really flat and doesn't even wheel spin

  4. #4
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    I will see what I can find out about them later this eve.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  5. #5
    Regular Member krazylegz's Avatar
    Join Date
    Dec 2009
    Location
    South Shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers nige your a star

  6. #6
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    http://www.ebay.co.uk/itm/Opel-Vectr...-/220736194965

    this is the same turbo, it does not have a diaphragm so you can't change that.. its a pretty straight forward turbo tbh.. i would doubt its the root cause of your problems, its just bottling it when you try to use it which suggests the fault should be elsewhere.. You seem to have changed everything else though.. I would still be looking for holes in pipes, but turbo shutdown and limp mode is generally from the solenoid tripping, normally when it encounters an overboost situation. if you can list the fault codes it may help a bit.. P0033, P0234 or P0235 are suspects, let us know.

    When you changed the actuator did you test the lever/arm it connects to to see if the wastegate opens easily as it could be sticky and gunked up, it needs to be smooth or the actuator can't do its job?

    actual turbo faults are more obvious http://www.vauxhall-turbochargers.co...leshooter.html
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  7. #7
    Regular Member krazylegz's Avatar
    Join Date
    Dec 2009
    Location
    South Shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Got this sorted everyone

    After changing practically every sensor going I was right with my first original thoughts, the vac pump. Changed it today and I've now done 48 miles in it trouble free, seems to have a load more power too

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Faulty MAF (I think)
    By gerryo in forum Engine & Drivetrain
    Replies: 5
    Last Post: 3rd March 2012, 14:08
  2. Does Faulty EGR cause less MPG?
    By markluk in forum Engine & Drivetrain
    Replies: 5
    Last Post: 24th February 2009, 21:32
  3. 04 vectra v6 cdti Faulty turbo
    By Ziggy in forum How much is it worth? (THIS SECTION IS NOW CLOSED)
    Replies: 0
    Last Post: 14th November 2008, 16:43
  4. V6 CDTI-faulty turbo diagnosed
    By diesel dog in forum Engine & Drivetrain
    Replies: 10
    Last Post: 7th June 2007, 01:06

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •