User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Thermostat Issue??

  1. #1
    Regular Member KeeronMac's Avatar
    Join Date
    Mar 2011
    Location
    Donegal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question Thermostat Issue??

    Hi guys, not sure if this is where I should post this question but here goes.

    I have noticed that my temp gauge barely moves, I did a quick search and seem to have all the symptoms of a dodgy thermostat i.e temp needle doesn't move, takes ages for heater to blow warm air etc.

    I took it to a garage and told him what I thought was the problem. He plugged in the computer and says that the sensor is working fine and that it is the actual gauge in the dash that needs replaced, although he said this was more hassle than needed as everything else was working fine. I'm not so sure though.

    He then said that it could be caused by the EGR, and strangely enough the spanner light wont turn off now??

    I'm going to clean the EGR myself, should I get the thermostat anyway??

    If so are the ones of ebay ok to get??

    Was looking at this:

    http://www.ebay.co.uk/itm/Vauxhall-V...item35b9f1151b

    Would that be ok?? Also need new brake discs and was wondering would these be ok?? I ask because they seem to be a very reasonable price, almost to reasonable

    http://www.ebay.co.uk/itm/VECTRA-C-1...item3f148115ad

    Car is an 05 reg Vectra, 1.9 CDTI

  2. #2
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Reading the listings,both those items on Ebay should be right for your car. Re the spanner light, did the garage say what the codes were that wont clear, that would help identify if the EGR is at fault.
    Personally i would replace the thermostat, they are prone to failing and ages to warm up and gauge issues are the main symptoms. Little bit of a pig to do, so allow a couple of hours.

  3. #3
    Regular Member Dane-10's Avatar
    Join Date
    Feb 2012
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Same symptoms as mine for the thermostat, I replaced it as chances are it was that and no the guage, Job was fixed, Now takes 5 - 7 miles to warm up of normal driving, get warm air within about 1 mile usually.

  4. #4
    Regular Member GCM's Avatar
    Join Date
    May 2007
    Location
    Coventry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi, I had the same engine temperature issues as you and brought the thermostat from the same seller last week and a genuine Vauxhall part was supplied. Fitted it easily in a couple of hours on Friday afternoon following the how 2 posted on here and all is ok now.

  5. #5
    Regular Member Chris B's Avatar
    Join Date
    Jan 2012
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by KeeronMac View Post

    Car is an 05 reg Vectra, 1.9 CDTI
    If yours is the 150bhp, just follow the how to - if its the 120.............. prepare for a nightmare - the EGR cooler bracket covers the lower bolt on the stat housing

  6. #6
    Regular Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Quote Originally Posted by KeeronMac View Post
    I took it to a garage and told him what I thought was the problem. He plugged in the computer and says that the sensor is working fine and that it is the actual gauge in the dash that needs replaced, although he said this was more hassle than needed as everything else was working fine. I'm not so sure though.
    Its the thermostat not the temperture sensor that has failed. The temperture sender will be working fine. Seems the man in the garage didn't know what he was talking about and could have eneded up costing you a load of dosh for no reason!

    Mind you if would be more costly for you for the garage to replace the dash gauge than to replace the thermostat and therefore a fast buck could be made by pretending to change the dash and instead doing the thermostat (or am I being a bit cynical)

  7. #7
    Regular Member mcpitman's Avatar
    Join Date
    May 2011
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Club

    Engine : 1.9 CDTi

    Year : 2004

    Default

    99% sure it's the stat. Thought my temp gauge was knackered qnd changed the complete stat and housing and all sorted.

    Tis a b***h on the 120.

  8. #8
    Regular Member mcpitman's Avatar
    Join Date
    May 2011
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Club

    Engine : 1.9 CDTi

    Year : 2004

    Default

    DP bug
    Last edited by mcpitman; 5th March 2012 at 20:04.

  9. #9
    Regular Member KeeronMac's Avatar
    Join Date
    Mar 2011
    Location
    Donegal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by barney490 View Post
    Reading the listings,both those items on Ebay should be right for your car. Re the spanner light, did the garage say what the codes were that wont clear, that would help identify if the EGR is at fault.
    Personally i would replace the thermostat, they are prone to failing and ages to warm up and gauge issues are the main symptoms. Little bit of a pig to do, so allow a couple of hours.
    He never mentioned what codes came up, never even thought to ask to be honest, I find it strange how the spanner light is up now after he said the EGR could be a suspect. The engine symbol under the fuel gauge is gone only to be replaced by the spanner...

    Quote Originally Posted by Chris B View Post
    If yours is the 150bhp, just follow the how to - if its the 120.............. prepare for a nightmare - the EGR cooler bracket covers the lower bolt on the stat housing
    It is the 120bhp I remember my friends dti was right at the front and easy enough to remove, yeah mine might be a bit more work...

    Quote Originally Posted by merikiito View Post
    Its the thermostat not the temperture sensor that has failed. The temperture sender will be working fine. Seems the man in the garage didn't know what he was talking about and could have eneded up costing you a load of dosh for no reason!

    Mind you if would be more costly for you for the garage to replace the dash gauge than to replace the thermostat and therefore a fast buck could be made by pretending to change the dash and instead doing the thermostat (or am I being a bit cynical)
    You see thats what I thought, I was thinking that the thermostat wouldn't be that expensive, probably not too awkward a job either, hence he said the dash, but if it was the dash surely the needle wouldnt move at all (it moves slightly if i put the foot down but drops straight away after), that made me doubt him slightly. Having said that he said not to bother changing the dash.

    He seemed genuine enough though, said it would be no problem if I wanted to source my own parts and he would fit them, rather have a go at it myself first.

  10. #10
    Regular Member KeeronMac's Avatar
    Join Date
    Mar 2011
    Location
    Donegal
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by mcpitman View Post
    99% sure it's the stat. Thought my temp gauge was knackered qnd changed the complete stat and housing and all sorted.

    Tis a b***h on the 120.
    Yeah I think I'll get the stat, hopefully that sorts it, car running fine bar that

    And is anything simple on the 120's???

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new thermostat
    By wildchild in forum Vectra C / Signum Troubleshooting
    Replies: 10
    Last Post: 24th August 2012, 14:02
  2. Can anyone tell me what a thermostat does?
    By twinxster in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 3rd February 2012, 22:03
  3. Thermostat Issue?? Or Something Else
    By Elahi_786 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 18th January 2012, 22:58
  4. Thermostat issue?
    By justin32 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 21st October 2011, 19:14
  5. Thermostat
    By shrekster in forum Engine & Drivetrain
    Replies: 4
    Last Post: 26th January 2009, 01:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •