User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Limp mode in 2003, 3.2 V6

  1. #1
    New Member
    Join Date
    Jan 2012
    Location
    Wollongong
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Limp mode in 2003, 3.2 V6

    Hoping somebody can help me out here before I wander off to see a mechanic.
    My car has twice now gone into what I can only surmise is a limp mode, the car spanner light comes on when this happens. It seems to have no power even changing through the gears (manual), drives ok but does not rev readily at all. When I stop the car and restart, it is OK again. The light has come on sporadically before, but has never stayed constantly on like this.
    We have had quite a lot of rain and I had to navigate through a moderately deep puddle, could this be a contributing factor?? And if so how?? Could there be something that has gotten wet that would affect the car like this??

  2. #2
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    Could be a dirty abs plug or a maf does it missfire at all
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  3. #3
    New Member
    Join Date
    Jan 2012
    Location
    Wollongong
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No has never misfired.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. limp mode
    By taxidriver50005 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 12th February 2012, 17:59
  2. 2003 2.2 sri ::limp mode::
    By Tommy3K in forum Engine & Drivetrain
    Replies: 1
    Last Post: 19th July 2011, 20:59
  3. Limp mode or dead mode
    By JSYSH466Y in forum Engine & Drivetrain
    Replies: 8
    Last Post: 2nd July 2009, 09:46
  4. Limp Mode...Again!
    By ChrisFox in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 15th July 2007, 17:47

Visitors found this page by searching for:

vectra c 3.2 in limp mode

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •