User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: problems with vectra 2004 diesel 120bhp

  1. #1
    Regular Member
    Join Date
    Feb 2012
    Location
    County Armagh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default problems with vectra 2004 diesel 120bhp

    Hi all, first time using the site (new member)

    I have a vectra 2004 120bhp 1.9cdti, number 3 injector went about 4 weeks ago, i got it replaced but i have noticed a drop in mpg, before the injector went i was getting 42-45mpg on short journeys and about 48-55 on long journeys, now i am getting 34-38 on short journeys and struggling to get over 42 on long journeys,

    i have noticed if i drive the car about half a mile to a mile there is heat coming from heaters but the car temp gauge hasnt moved, but if i drive the car for about 5-6 mile the temp gauge moves to about 85 and stays there with the heat on or not, i replaced the temp sensor about 2 years ago when i got the car, but not the thermostat

    Also i have topped up the coolant bottle 3 times since the new injector has been put in (4 weeks ago), since i have found out there is a pin hole in the radiator, i have put rad weld in but no help.

    Why has the mpg dropped, would the new injector have caused this? Please help, before i was getting 2 weeks from a tank, now im getting 1 week from a tank,

    Thanks in advance

  2. #2
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    First, I would take off the top plastic engine cover and just check that the spill pipe linking the top of the injectors has been broken. If it has you will get a strong smell of diesel and see it pooling round the injector. I cant think why replacing an injector would significantly increase your fuel consumption, unless it is either faulty or the wrong one. I do know these need TECH2 when a new injector is fitted, to tell the ecu the settings, perhaps check with the fitter that this was done.
    Secondly, it sounds like you car is warming up as it should. Your description of warm up distance is about bang on for a 120, so i would say the thermostat is fine.

  3. #3
    Regular Member
    Join Date
    Feb 2012
    Location
    County Armagh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sorry forgot to say, mine is the 150bhp engine but it only puts out 120bhp, also forgot to say the rear brake calipers are sticking abit, thanks for the reply

  4. #4
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Quote Originally Posted by DavyB View Post
    sorry forgot to say, mine is the 150bhp engine but it only puts out 120bhp, also forgot to say the rear brake calipers are sticking abit, thanks for the reply
    There is your MPG problem - the sticking calipers...

    Why do you say its only putting out 120?

    When was the last good service with all filters - incl Fuel?

    Have you had a diagnostics readout at all... You do need to make sure that the injectors have been coded to the car... this can be done with VauxCom or tech ii

  5. #5
    Regular Member shb1988's Avatar
    Join Date
    Oct 2010
    Location
    sittingbourne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    2 Thread(s)
    Vehicle InfoStats





    Default

    It could be one of the few 1.9 16v diesels which were down tuned to be the 120,

  6. #6
    Regular Member Barlow's Avatar
    Join Date
    Jan 2012
    Location
    Chester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan 350Z GT


    Engine : 3.5 V6

    Year : 06

    Mileage : 50,000

    Default

    Quote Originally Posted by DavyB View Post
    i have noticed if i drive the car about half a mile to a mile there is heat coming from heaters but the car temp gauge hasnt moved, but if i drive the car for about 5-6 mile the temp gauge moves to about 85 and stays there with the heat on or not, i replaced the temp sensor about 2 years ago when i got the car, but not the thermostat
    I replaced my thermostat today and went for a 20 mile drive and mine acts exactly as yours does. I presume this is normal.

  7. #7
    Regular Member DAVIDD88's Avatar
    Join Date
    Jan 2011
    Location
    scottish region
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by shb1988 View Post
    It could be one of the few 1.9 16v diesels which were down tuned to be the 120,
    That was only astras they done that with

  8. #8
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default


  9. #9
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You really need to clean your calipers and stop them fom binding, apart from the drop in MPG, you will also overheat the discs and possibly warp them.

  10. #10
    Regular Member
    Join Date
    Feb 2012
    Location
    County Armagh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by DAVIDD88 View Post
    That was only astras they done that with
    I checked with the MID (Motor Insurance Database) and it come back as a 2004 Vectra 120. As far as i can see number 3 injector was replaced before, this will be the 2nd injector put into injector number 3, hopefully the last. my flywheel is starting to go, oh what joy lol

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 10th December 2012, 15:13
  2. How to fit an alarm on a Vectra C 2004 2.0 Diesel?
    By cornel18 in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 23rd January 2011, 20:29
  3. 2004 vectra 3.0 v6 diesel automatic gear box
    By vectra 3.0v6 sri in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 21st November 2010, 23:05
  4. starting problems 2004 vectra 1.9 deisel
    By higgy7511 in forum Engine & Drivetrain
    Replies: 26
    Last Post: 25th October 2010, 00:39
  5. Problems with my vectra c diesel
    By george120879 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 6th October 2009, 02:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •