User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Metal screech turning left

  1. #1
    Regular Member Cruize's Avatar
    Join Date
    Dec 2009
    Location
    South East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Metal screech turning left

    So yeah, when driving if i'm turning left the OS wheel screeches. Sounds like a metal on metal screech. Checked the discs and pads and they're fine, had loads of brake cleaner on them as thought maybe some crud stuck in them. jacked the wheel up and its free spinning as next I though caliper may be sticking but clearly not.
    Any ideas? Next thought was maybe a wheel bearing?
    Like I said sounds like a metal on metal screech. Anyone had this?

  2. #2
    Regular Member Al 22 dti's Avatar
    Join Date
    Mar 2011
    Location
    pontefract
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 57 zafira 1.9 cdti design

    Trim : design

    Engine : 1.9 cdti

    Year : 2008

    Default

    check the brake disk shield at the back to make sure its not too close to the brake disk.

    its no 17 in this diagram.

  3. #3
    Regular Member Cruize's Avatar
    Join Date
    Dec 2009
    Location
    South East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok will do. how do I adjust it if it is?

  4. #4
    Regular Member ollie {150}'s Avatar
    Join Date
    Jul 2010
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had the same last week and the shield was close too the disk so I carefully prized it back and all sorted!

  5. #5
    Regular Member Cruize's Avatar
    Join Date
    Dec 2009
    Location
    South East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That was my 1st idea, brute force in pulling it back but it's landed me in trouble before lol so just better check if there's an official way of doing it lol :P

    Was yours only when turning??

  6. #6
    Regular Member themarbleman's Avatar
    Join Date
    Mar 2010
    Location
    sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked your cv boot/joint?

  7. #7
    Regular Member ollie {150}'s Avatar
    Join Date
    Jul 2010
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes just when turning I thought it was quite strange. I diddnt pull it too hard as it was quite rusty lol

  8. #8
    East Midlands - Regional Organiser new boy's Avatar
    Join Date
    Nov 2010
    Location
    lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    48 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BTCC Edtion

    Trim : SRI LEATHER

    Engine : 2.0 TURBO

    Year : 07

    Default

    Broken spring?

  9. #9
    Regular Member
    Join Date
    Jun 2008
    Location
    South east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No brute force necessary, moving the dush shield away from the disk is just like bending a paper clip.

  10. #10
    Regular Member Cruize's Avatar
    Join Date
    Dec 2009
    Location
    South East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Broken spring you would feel in the steering followed by a clung lol had that before on a old mondeo. Its only just had its MOT so CV joint / boot i'm sure would have been flagged. I'll check the brake shield. Sounds like a possible culprit

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. squeak when turning left
    By chris1804 in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 13th August 2012, 12:37
  2. Knocking from front turning left
    By mwjy1972 in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 14th April 2011, 18:21
  3. squeak sound when turning left and right
    By gibbon7000 in forum Suspension, Wheels & Brakes
    Replies: 3
    Last Post: 24th January 2010, 22:17
  4. Cold Turning Left
    By spennny in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 9th January 2009, 21:38
  5. turning left right brake squeaks
    By junior72 in forum Suspension, Wheels & Brakes
    Replies: 0
    Last Post: 18th August 2008, 15:55

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •