User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: oil filter wont budge!

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    brum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default oil filter wont budge!

    After 3 hours of trying, i just can't get my oil filter housing to unscrew, i maybe managed to turn it 1mm. I tried molegrips, spanner, and some massive socket with a bar through it and nothing would work.

    Due to the oil filter being at the bottom, i have to access it from underneath, which means i have limited space to really get anything substantial in there (like an air gun, which i dont have but still...).

    I gave it a spray of lubricant round the toothed edge and left it for 10 minutes but that didn't help either.

    Does anyone have any idea's as to how to get the blasted thing off ? is there a fancy tool that can be used to make it simpler (baring in mind ive put a fair bit of pressure on it with a spanner and a funky socket thing, so its definitely solid on there).

    Thanks for any help

  2. #2
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Try warming the engine up?

  3. #3
    Regular Member
    Join Date
    Jun 2011
    Location
    brum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yup, had to drive to my dad's work where i was doing it. 20 minute drive then it sat for about an hour and half while i done my dad's oil. So it would have still been warm (could feel it radiating out the engine bay when i popped the bonnet so i imagine it was warm enough)

  4. #4
    Regular Member
    Join Date
    Jun 2011
    Location
    Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine was like that. tight as a cats rrrrrrrs. the right sized socket and steady force while she is at full working temp is the best bet. might be best to wait until thee is a stealers or scrappy open in case it gives up the ghost in the process.

    not lubricating the new o ring when it was tightened or an over zealous spanner monkey are the most likely causes.

    Luckily my sump plug was only hand tight though.

    also might be worth a try tightening it a little more as any movement may help free it.

  5. #5
    Regular Member
    Join Date
    Jun 2011
    Location
    brum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah i tried forcing it in both directions as i started to question whether it was a reverse thread or not. I might try and get one of those low profile sockets and have another crack at it. The main problem is simply getting room to really put some pressure on it, getting to it from the top is a nightmare, and underneath the exhaust is almost directly below it.

    I'll have another crack at it tomorrow... If that doesn't work i'll have to pay a garage to do it for me.

  6. #6
    Regular Member
    Join Date
    Jun 2011
    Location
    Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    low profile socket and an extension bar if you can get one on it. good luck buddy.

  7. #7
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what engine is it ??

  8. #8
    Regular Member
    Join Date
    Jun 2011
    Location
    brum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    1.9 CDTi 120 , facelift model

    Don't look like halfords sell the low profile socket according to their site, luckily i found a place about 30 mins drive away. So i'll have to have a drive up in the morning and hopefully they're open

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    they are an element arent they ??

  10. #10
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Yep, in a plastic housing at the rear and low down on the engine.
    Add the exhaust and steering rack and you get a piece of class Italian design making the most important DIY job a pain. Should be torqued to 20 - 25nM. Some people tend to think the tighter the better.
    Also be aware there is a little plastic drain pipe on the underside of the filter housing so you get warn oil up your sleeve.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra c 2.0 DTI 02 EGR will not budge!
    By richardkay007 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 15th July 2011, 12:34
  2. passenger seat jammed right back on runners and wont budge!
    By richiem in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 21st April 2011, 22:28
  3. odd staining on front headlight lens that wont budge?
    By richiem in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 11th April 2011, 20:17
  4. Wiper linkage broke - ****ing scuttle panel wont budge
    By eaglepva in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 23rd January 2011, 17:16
  5. Help..indicators wont budge!
    By Dwabo in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 5th February 2008, 20:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •