User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Heating and blower problem?

  1. #1
    Regular Member
    Join Date
    Feb 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heating and blower problem?

    The only other problem i have with my car lol,
    The heater settings only worked on No. 4, After reading many forums i managed to find out about the "Resister", anyway i brought a new one from ebay and i now have all settings but with a glitch,
    Setting 1 = Blows slowly
    Setting 2 = Blows slowly (no change from setting 1)
    Setting 3 = Blows slowly (no change from setting 1)
    Setting 4 = Full Speed (fast)

    Any ideas to this?
    The heating in my car is crap also, only blows slightly warm air, Well it only feels warm when you have your hand/s on the vents lol, So in other words i freeze when its cold out lol. If i leave the engine running while in stationary and the temp guage goes to half way i get hot air, but turning the heating on cools my engine and then my heating goes cold again

    Any advice would be brilliant thanks.

  2. #2
    Regular Member
    Join Date
    Mar 2011
    Location
    Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The problem may be your pollen filter. If the pollen filter is choked up little air will get through to your vents.

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No change in the blower speed on some switch setting sounds a bit like a a resistor pack problem. I seem to remember you can buy these as a spare part so they must fail often.

    Would be worth your while searching here for answers.
    Don't know if it's a big job or not to change it.

    As for the lack of heat, sounds like your thermostat is stuck open.
    Mine did the same, temperature guage was usually below 70 unless stuck on traffic. I did get heat though, just not much & was never good enough in winter.

    A quick test..if you are stopped in traffic & the temperature gauge is mid point & you then put the heater blower on full & the temperature gauge drops back to less that 80, then you need a new thermostat.

    There's a great guide to changing it in the "How to" section.

    Gerry

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Change your thermostat. For lack of heat

    And resistor pack for the settings problen

  5. #5
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Double post

  6. #6
    New Member
    Join Date
    Feb 2012
    Location
    galway
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi have same lack of heat problem changed thermostat but still the same any ideas?

  7. #7
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Quote Originally Posted by 123mark View Post
    Hi have same lack of heat problem changed thermostat but still the same any ideas?
    Is the car getting and staying at temp ok?

    Could be blocked heater matrix

  8. #8
    Regular Member
    Join Date
    Feb 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by gerryo View Post
    No change in the blower speed on some switch setting sounds a bit like a a resistor pack problem. I seem to remember you can buy these as a spare part so they must fail often.

    Would be worth your while searching here for answers.
    Don't know if it's a big job or not to change it.

    As for the lack of heat, sounds like your thermostat is stuck open.
    Mine did the same, temperature guage was usually below 70 unless stuck on traffic. I did get heat though, just not much & was never good enough in winter.

    A quick test..if you are stopped in traffic & the temperature gauge is mid point & you then put the heater blower on full & the temperature gauge drops back to less that 80, then you need a new thermostat.

    There's a great guide to changing it in the "How to" section.

    Gerry
    Thanks Gerry, Ive replaced Resister pack, brought from ebay but may buy another just incase its faulty and yea, When im in traffic Temp Guage goes to the Half way mark, If i then put heating on it drops and when im driving it stays on quarter (below half), So does that mean i need a new Thermostat? Thanks

  9. #9
    Regular Member
    Join Date
    Feb 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Could any1 explain to me about the heating, Taking passenger glovebox and footwell covering off to get to some red thing (i think) that apprently jams lol Stopping from switching to hot air or something, Ive read about it somewhere but cant seem to find it again lol. Sorry to be a Dumbass. Thanks

  10. #10
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Remove glove box. Remove plastic that would be by right foot if sitting in pass seat, remove air ducting pipe ( held in with a torx screw behind motor)

    Then you will see the red/ pink lever.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. heating problem
    By keithv1 in forum Vectra C / Signum Troubleshooting
    Replies: 13
    Last Post: 13th January 2013, 17:46
  2. Heating problem
    By Bezz! in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 13th April 2010, 16:39
  3. Heating Problem - Vec C 2.0 DTI
    By bidey89 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 3rd March 2010, 12:38
  4. Problem with heating...
    By mickg in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 15th January 2010, 07:56
  5. 2.0 dti heating problem
    By jmacp in forum Bodywork & Interior
    Replies: 5
    Last Post: 23rd November 2008, 13:42

Visitors found this page by searching for:

what temperature on the guage on renault scenic read half way

vectra c fan not blowing as fast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •