User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Heater Query

  1. #1
    Regular Member LeylandRick's Avatar
    Join Date
    Jan 2012
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater Query

    Hi all.
    having been spoilt with Mondeo heated front screen and a superb heater/blower system then got up to temp within minutes i am feeling a little let down by the signum. maybe its a fault - i dont know.

    Setting 1,2 are really poor, almost nothing comes from them, i have to whack it up to 4, or hit the boost/recycle button to get a good blast out of the mid level vents. As for the footwell and screen vents - nothing...

    is this the norm, or has anyone else encountered poor performance issues. I would prefer not to have to keep hitting my boost and screen clear buttons all the time.

    cheers

    Rick

  2. #2
    Regular Member cossie's Avatar
    Join Date
    Mar 2006
    Location
    MANCHESTER
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by LeylandRick View Post
    Hi all.
    having been spoilt with Mondeo heated front screen and a superb heater/blower system then got up to temp within minutes i am feeling a little let down by the signum. maybe its a fault - i dont know.

    Setting 1,2 are really poor, almost nothing comes from them, i have to whack it up to 4, or hit the boost/recycle button to get a good blast out of the mid level vents. As for the footwell and screen vents - nothing...

    is this the norm, or has anyone else encountered poor performance issues. I would prefer not to have to keep hitting my boost and screen clear buttons all the time.

    cheers

    Rick
    Check your pollen filter is clean - a dirty one severely restricts the airflow and in extreme cases can cause your car to mist up easy HTH

  3. #3
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As above ... Also if blocked water can ingress into the blower resistor pack and as such could have from what you'd saying already damaged the lower settings .. Are you sure that there is any airflow on settings one and two ??

    0-Large smile ......every time it's driven

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Heater query?
    By ScottyV6 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 19th November 2012, 23:10
  2. MAF query
    By ScottyV6 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 12th June 2011, 15:33
  3. Air Con Query
    By eddie twadds in forum Vectra C / Signum Troubleshooting
    Replies: 12
    Last Post: 24th May 2010, 01:31
  4. Car reg query
    By Matty H in forum General Chat
    Replies: 12
    Last Post: 8th July 2008, 14:10
  5. M P G Query
    By Johny Tango in forum Engine & Drivetrain
    Replies: 7
    Last Post: 15th May 2007, 16:44

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •