User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Pulsing boost prob NOT fixed!

  1. #1
    Regular Member
    Join Date
    Sep 2011
    Location
    Caerphilly
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : saab 93 tid(150)

    Trim : sport

    Engine : 1.9 z19dth

    Year : 2005

    Mileage : 63000

    Default Pulsing boost prob NOT fixed!

    I recently posted that the pulsing boost im getting under load is fixed, but its returned which is annoying, its on my saab 93 (z19dth) , changed the boost controller which seemed to cure it but not for long, im begining to think its my inlet manifold causing it as i had to fix the swirl rod back on a while ago, it is still on but very loose and ive got gunk and fresh oil on each swirl flap, could it cause the pulsing boost im getting?, ive read a few posts on here with a couple of guys describing same symtoms, did any of you find a cure? Cheers

  2. #2
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    There are two boost controller for this engine - well on the Vectra/Signum anyway. One I believe is if you have the engine with the vacuum reservoir at the back. If you have then if you follow the turbo vacuum pipes from the vacuum pump it will join onto a metal pipe, this will head down the back of the engine. Next to that metal pipe there is another one that follows the exact same path it will join onto the other vacuum pipe.

    The other type of vacuum system misses the vacuum reservoir out completely.

    This is the need for the two different types of boost controller. I know I have the same issue as you and bought the wrong one.

  3. #3
    Regular Member
    Join Date
    Sep 2011
    Location
    Caerphilly
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : saab 93 tid(150)

    Trim : sport

    Engine : 1.9 z19dth

    Year : 2005

    Mileage : 63000

    Default

    Cheers for the quick reply i have got a vac box at the back of the engine but bypassed after reading i could, ive not noticed or heard of another boost controller on these engines mine is a 2005 , i changed the one under the slam panel at the front with the two vac pipes connected

  4. #4
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by Richard.roberts View Post
    Cheers for the quick reply i have got a vac box at the back of the engine but bypassed after reading i could, ive not noticed or heard of another boost controller on these engines mine is a 2005 , i changed the one under the slam panel at the front with the two vac pipes connected
    There are definitely two n the Vec as I bought the one for the engine without. I would double check if there are two. If you bought one for an engine without a Vac box it may still cause the problems. I think this is the issue with mine. Albeit I haven't bypassed the vacuum box but if it's there the ECU will be using the boost controller like the vac box is there, and subsequently as the boost controller you have may not be for this engine it may not be working as designed to.

  5. #5
    Regular Member
    Join Date
    Sep 2011
    Location
    Caerphilly
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : saab 93 tid(150)

    Trim : sport

    Engine : 1.9 z19dth

    Year : 2005

    Mileage : 63000

    Default

    Thanks for that mate il connect the vac box back up and try , and have a look for the other controller , i defo need a new inlet manifold though but gona take me e few weeks to save up, been doing my homework on changing it ,awsome how2's on here. Anyway this pulsing doesnt happen if i accelerate by feathering the throttle in , only when i floor it 3rd or higher!

  6. #6
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by Richard.roberts View Post
    Thanks for that mate il connect the vac box back up and try , and have a look for the other controller , i defo need a new inlet manifold though but gona take me e few weeks to save up, been doing my homework on changing it ,awsome how2's on here. Anyway this pulsing doesnt happen if i accelerate by feathering the throttle in , only when i floor it 3rd or higher!

    Same here mine does the exact same.

  7. #7
    Regular Member
    Join Date
    Sep 2011
    Location
    Caerphilly
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : saab 93 tid(150)

    Trim : sport

    Engine : 1.9 z19dth

    Year : 2005

    Mileage : 63000

    Default

    Do you know what the other controller looks like?

  8. #8
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    Quote Originally Posted by Richard.roberts View Post
    Do you know what the other controller looks like?

    On the Vectra it's a wee black box and there is a cream coloured bit at the end that the vacuum pipes go into - the one from the vacuum pump and the one going to the turbo.

  9. #9
    Regular Member
    Join Date
    Sep 2011
    Location
    Caerphilly
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : saab 93 tid(150)

    Trim : sport

    Engine : 1.9 z19dth

    Year : 2005

    Mileage : 63000

    Default

    Thats the one ive changed! It was used but it didnt solve my prob

  10. #10
    Regular Member
    Join Date
    Sep 2011
    Location
    Caerphilly
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : saab 93 tid(150)

    Trim : sport

    Engine : 1.9 z19dth

    Year : 2005

    Mileage : 63000

    Default

    How did you know which one was the right one , by the number stamped on it is it? And if so do you know the number for the one with vac box cheers

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pulsing boost prob finally fixed!
    By Richard.roberts in forum Engine & Drivetrain
    Replies: 2
    Last Post: 19th February 2012, 23:50
  2. HELP!!! Engine Pulsing and wont go over 4k revs!!
    By sub2199 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 6th December 2010, 10:26
  3. Boost sensor prob
    By wolvesdaz in forum Engine & Drivetrain
    Replies: 6
    Last Post: 7th October 2010, 20:53
  4. Pulsing boost
    By Gazza36 in forum Engine & Drivetrain
    Replies: 26
    Last Post: 29th April 2010, 17:58
  5. LED Flashing / pulsing
    By Steven T Davies-Moss in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 30th October 2009, 22:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •