User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: vectra cdti injector problem...

  1. #1
    New Member
    Join Date
    Feb 2012
    Location
    Newcastle upon tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Question vectra cdti injector problem...

    Hello, am a newbie to the vectra c sri cdti 150 just bought a 56 plate veccy and hasnt been off to a good start either... had the car few month now already had a thermosat on it

    BUTTTT now....

    i have a leaking injector on number 3! so after alot of garages saying they wont be able to remove it as it will be locked soilid and other garages wanting £££'s i found a very local garage to me agreed to remove injector mega clean it up! cleaned the bore + new copper washer and new 'O' ring etc etc... and sort my problem out he'd done loads diesels injectors good named garage LONG STORY CUT SHORT!
    (am aTART with my cars wont use any tom,dick or harry btw)

    so as of monday heres whats happened,

    MONDAY round.1 = FAIL! still leaking louder and worse..
    (so took it back next day)

    TUESDAY round.2 = MEGA FAIL i got about 1mile away and car was undrivable had to be towed back to garage..smoke every were!!!
    (leaking worse then ever!!!) was like a train!!!!!!!

    WEDNESDAY round.3 = SUPER FAIL garage can not get injector sealed back in???? rang me to have a look said its not getting a seal we keep trying going to try new stud bolt to get the injector locked in better as my stud (which holds injector in is higher then others??? hmmmm?)..

    Soooo ive had a qwick look/read though search bar and found bits and bobs about injectors but still abit lost on them? whats my best way of action because i'm now carless + fed up and sick to be honest now any ideas ive seen its a common problem is there any good link help tips would be great to pass info on to garage to try?

    who ever put this FIAT engine in my vectra needs shot!!!

    sorry tried my best to explain as am rubbish at explaining things sorry inadvance and obv a re-post,

    Kev

  2. #2
    Regular Member MrDerv's Avatar
    Join Date
    Nov 2011
    Location
    North East (Beamish)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by betrayed View Post
    who ever put this FIAT engine in my vectra needs shot!!!
    Technically it's as much as a GM engine than it is Fiat, it's a result of a failed merger between the two companies a few years ago.

    I guess the only thing you could get them to retry the job. From what i've heard, the copper washers are a pain, but once they're in right, problem sorted

  3. #3
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well, one of my injectors has leaked really since I bought the car 6 years ago. I decided to leave well alone and now it appears to have sealed itself. I blast the car once a week, 4.5K rpm for a few minutes. No problems.

    My motto is, if it is not causing great grief then leave well alone.

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Are they fitting a new copper washer each time they take it out?

    They may have damaged the seat by cutting too much or something as well.

    Could always try a small bit of exhaust paste. And use it a bit like grinding paste. Using the injector and see if that helps seal it.

  5. #5
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Double post gremlins

  6. #6
    New Member
    Join Date
    Feb 2012
    Location
    Newcastle upon tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    todays update THURSDAY...

    I phoned the garage today to see the progress.. he says the injector leak is fixed but now my cars running on three pots...

    FML...

    so would it have damage my ijector? OR will it need programed in again? or will it be the lines/wires making it run on 3 pots

    any ideas lads?

  7. #7
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Perhaps they damaged injector nozzle having it in and out so much.

    Or damaged wiring or something

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Perhaps they damaged injector nozzle having it in and out so much.

    Or damaged wiring or something

  9. #9
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Inj no.3 has a known fault with the plug and there is a new plug/loom availabvle from VX.

  10. #10
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    The leak hasn't been fixed m8 by the sounds of it and I would say if your injector plugs are Yello there is a very good chance that's the problem. There is an issue the old style injector plugs (especially the one on the 3rd injector) start to go bad and dirty and need replaced with the newer upgraded Blue version. This issue causes the car to eventually start shutting down. Dealers can fix them all for about £130. The part istelf is £12 from the dealer. You would need 4 of them if you're going to do all injectors.

    Quote Originally Posted by MrDerv View Post
    Technically it's as much as a GM engine than it is Fiat, it's a result of a failed merger between the two companies a few years ago.
    Certainly more Fiat m8, Alfa and Fiat have used this engine since 1997 and have developed it ever since. It was the first common rail diesel in a passenger car according to popular links.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 Vectra 1.9 CDTi 150 injector seal
    By MXB74 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 11th March 2012, 18:38
  2. Cdti injector problem
    By aidy-cdti in forum Engine & Drivetrain
    Replies: 2
    Last Post: 27th June 2011, 20:19
  3. Vectra V6 CDti Injector problem possibly?
    By smitd004 in forum Engine & Drivetrain
    Replies: 21
    Last Post: 1st June 2011, 21:14
  4. 2005 Vectra 1900 CDTi 150 Injector Leaking
    By MXB74 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 2nd February 2011, 23:17

Visitors found this page by searching for:

vectra 1.9 cdti leaky injectors www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •