User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Engine and clocks died

  1. #1
    Regular Member big gra's Avatar
    Join Date
    Dec 2011
    Location
    southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine and clocks died

    Other day all dials went dead, fuel revs speed etc, i get a symbol of a steering wheel with an ! in it. Just parkd car up, went to move it again and get nothing when i turn the key. Any ideas? Oh and its an 03 2.0 dti

  2. #2
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    CIM has sadly failed

  3. #3
    Regular Member big gra's Avatar
    Join Date
    Dec 2011
    Location
    southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by m8internet View Post
    CIM has sadly failed
    whats a cim and is it expensive? The cars bin runin fine and startin fine, otherwise i would of said it was the battery

  4. #4
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    Quote Originally Posted by big gra View Post
    whats a cim and is it expensive? The cars bin runin fine and startin fine, otherwise i would of said it was the battery
    I would try a fully charged battery before you do anything else - or alternatively consider the alternator

  5. #5
    Regular Member neill's Avatar
    Join Date
    Nov 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRI

    Engine : Z19DTH

    Year : 2004

    Mileage : 172000

    Default

    as above try the battery first

  6. #6
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    And check all the fuses, including the master fuses, and the ignition relays.

  7. #7
    Regular Member big gra's Avatar
    Join Date
    Dec 2011
    Location
    southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not very happy this has happened, only had it two weeks and have spent lots on wheels lights hids etc

  8. #8
    Regular Member disco dan's Avatar
    Join Date
    Apr 2011
    Location
    Southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its not what ya want is it gra, the day after I bought mine I got the spanner light come on. Had an ongoing fault ever since and its just got sorted! I shouldn't of modded so much and I'd of prob got it fixed earlier!

  9. #9
    Regular Member big gra's Avatar
    Join Date
    Dec 2011
    Location
    southport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just bin out to hav a fiddle n it started up fine, clocks all work fine. Dont dare go anywer in it though. Any thoughts?

  10. #10
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    let it idle upto running temp and see if it happens again, if it does cranck shaft speed sensor is on its way out about £40 if you can fit DIY

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. engine has just died please help
    By reeseandellie in forum Engine & Drivetrain
    Replies: 8
    Last Post: 6th August 2012, 12:47
  2. vectra 120 cdti engine died suddenly
    By donniecdti in forum Engine & Drivetrain
    Replies: 2
    Last Post: 20th March 2010, 10:31
  3. Engine Died
    By Diet1985 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 28th January 2009, 00:54
  4. engine died wont start anymore
    By PeteRs in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 19th July 2008, 17:55
  5. Engine died and won't start!
    By Snoddy in forum Engine & Drivetrain
    Replies: 8
    Last Post: 6th January 2008, 18:10

Visitors found this page by searching for:

vectra c 1.9 died wont start

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •