User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: vec 1.9 150 running weird

  1. #1
    Regular Member
    Join Date
    Mar 2010
    Location
    argyll, scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vec 1.9 150 running weird

    Hi all hope you can point me in the right direction to fix my problem !?!?!

    Every so often my car seems to not want to go over 2k revs when driving, it seems to happen when youre slowing down for junctions or taking off again and recently once in a while it takes ages to start then cuts out then starts and all is fine.

    Ive had it on the code reader and pedal test and nothing shows up, the mechanics baffled aswell.

    My thoughts are :-

    1. clean the egr valve and boost sensor
    2. clean the MAF (any tips for this )

    Anything else anyone could suggest to solve this would be great.

  2. #2
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    agree on steps one and two.

    Be very careful with the MAF.. ONLY spray contact cleaner on them - nothing else..

    On my DTI engine in my Saab I sprayed some electrical contact cleaner through the MAF as I had bad hesitation and the difference was brilliant.

  3. #3
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check the swirl bar is intact

  4. #4
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Quote Originally Posted by dh.dti View Post
    check the swirl bar is intact
    Agree - thats the next thing... Make sure your inlet isnt goosed!

  5. #5
    Regular Member
    Join Date
    Mar 2010
    Location
    argyll, scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    how do i check the swirl bar ?

  6. #6
    Regular Member Timmy2010's Avatar
    Join Date
    Feb 2010
    Location
    Solihull/Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    my cars broke down with the same thing 5 times this week took the EGR off and it was full of crap! cleaned it up and runs like a dream now!

  7. #7
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    EGR Valve if jammed open will not let the engine rev well but, wont show any fault sign. Sames goes for the swirl bar.
    Last edited by GazVXLINE170; 16th January 2012 at 23:47.

  8. #8
    Regular Member ScotsDragon's Avatar
    Join Date
    Aug 2009
    Location
    Lost in Time and Space...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 50000

    Default

    I cleaned my EGR and boost valve on sunday and the car feels totally transformed, the egr was stuck open and boost sensor was covered in gunk., Going to semi blank EGR and install oil catch tank and see if that helps.

  9. #9
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    what colour is the third injector plug, yellow or blue? If it yellow get the plug changed with a blue one. Modified part/kit is availble form VX for about £10
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3.0 V6 weird running & idle
    By s2yob in forum Y & Z30DT Specific
    Replies: 19
    Last Post: 3rd October 2011, 20:29
  2. Bit Of A Weird One This
    By Tam80 in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 18th February 2011, 15:52
  3. Weird???
    By mc_orion in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 18th January 2008, 21:15
  4. Weird!
    By Jamie in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 22nd October 2006, 22:08
  5. Weird MPG
    By spoons in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 22nd July 2006, 23:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •