User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 3.0CDTi Throttle body?

  1. #1
    Regular Member
    Join Date
    May 2010
    Location
    Berkshuire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 3.0CDTi Throttle body?

    Hi all

    Thanks for picking up this thread.

    Early yesterday out in our 3.0CDTi and the EML light came up, which is'nt unusual in this car as its come on before and been into Vauxhall who did not detect any faults. The couple of times its happened turning off the ignition seems to clear the light away. So yesterday morning the light came on and we pulled over to see if it would go away after turning off. Thats when the trouble hit us because after turning off the car would not start, it was turning over with no trouble but would not start. We got the RAC out who came up with an error relating to the glow plugs and the throttle body, he could not get it sorted at the roadside but we were only half a mile down the road from a garage that we knew the owner of so we got it towed to the garage.

    My question is does anyone know what it could be? and is a local type of garage going to be able to fix it? I am loathed to take it into VX as they did not detect anything last time and after our other car needed a lot of work last week we just cant afford another expensive job at main dealer rates.

    I read something a while ago about field service remedy or kits for this particular car but cannot find anything now, is that likely to be part of our problem? Thanks all.

  2. #2
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri

    Engine : 140 Ecoflex S/S

    Year : 2013

    Default

    What fault codes did the RAC flag up? Each one should have four digits .

    If the engine was warm and wouldn't restart immediately, a faulty glow plug circuit shouldn't make much difference.

    Did you get the spanner light come on (in the space where the "door open" symbol is) or just the EML warning light (the one that looks like an engine atthe far right hand side of the waring lights) ??

    Where abouts in Berkshire are you?
    Last edited by gtr1000; 16th January 2012 at 08:15.

  3. #3
    Regular Member
    Join Date
    May 2010
    Location
    Berkshuire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If I remember correctly both the spanner and the EML light came up.... which is actually unusual for our car. Looking at the picture in this thread

    http://www.vectra-c.com/forum/showthread.php?t=150552

    The light that has appeared in the past in our car is the 'spanner' symbol, the EML light has not come on before. However last night both the spanner and EML came on and the engine refused to start.

    The RAC guy did not give any fault codes, and at the moment the car is in a garage in Stoke Poges which is just inside Bucks.

  4. #4
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri

    Engine : 140 Ecoflex S/S

    Year : 2013

    Default

    Can you get the garage to read the fault codes? Then come back to the forum with codes and see if we can work something out before letting the garage have a tinker - don't be hasty .

    These engines, depending on what's wrong, can be quite (very ) specialised and it's very hard to find a garage/mechanic that know's what's what. Even VX stealers struggle with the V6 CDTi.

  5. #5
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : very

    Engine : Z19DTH

    Year : Nosey

    Default

    Could be the same fault I had with my 1.9CDTI. There is a fault with some of the older throttle bodies (the butterfly valve in the intake) that causes them to do the opposite of what they should do. When you try to start the car the butterfly valve closes and thus stops any air getting to the engine. If would sound like the engine is struggling to turn. You can just unplug the butterfly valve to fix it for the short term. If you remove the hose onto the Valve and manifold, you should be able to see the butterfly valve and see if it is closing when you try to start the engine. RAC and AA vans do not have sufficient diagnostix gear to find alot of faults or even read some engine fault codes. The guy had no idea what was wrong with mine and I just used him to help me diagnosis it. Take a look at the butterfly first.

  6. #6
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri

    Engine : 140 Ecoflex S/S

    Year : 2013

    Default

    Any update on this one .

  7. #7
    Regular Member
    Join Date
    May 2010
    Location
    Berkshuire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry guys by the time I checked back on this forum the garage had already got tinkering

    However they have got the car working, the problem was apparently that the throttle body and EGF were hideously sooted up with carbon deposits, far more so than usually expected for such items. So by the time I came back to these forums the garage had phoned me and confirmed the RAC report about the various diag. faults and proceeded to 'tinker' Having disconnected the main large hose into the throttle body they saw the carbon deposits so took it off and cleaned it up, also cleaned the EGR valve and reassembled, now its running perfectly except the service light is still on. The garage ran the diag. again and found the same fault concerning the glow plug relay which would not clear and suggested replacing the item, with an estimate of £80 for the part and £80 for the labour however I am an aircraft engineer by trade so will tackle this problem myself. The service light will apparently go when the glow plug problem is fixed. I'm not sure whether to go straight in and change the relay or change the plugs themselves, is there any method of testing the relay? The car has just touched 60,000miles is it time for new plugs anyway?

    When I was told about the serious sooty deposits I was of course quite concerned with what caused such heavy sooty deposits. Then I remembered a few weeks ago whilst the wife was out with the car she reported a loss of power and a lot of black smoke and limped home with the car. I was away on business so suggested she take it to the VX dealer (it was due a service anyway) and they found a large hose connecting from intercooler to throttle body had a 3" split along its length they did the service and replaced the hose and all was well again. I presume the soot really built up in those journeys home and to the garage and over the last few weeks its only gotten worse and finally got to the point where something got sticky in the throttle body.

    Now whilst your reading I have a couple of questions that I would appreciate some advice, if you dont mind of course

    1) Is there any kind of manual available for the Signum? or even just this engine

    2) In the second picture in this post http://www.vectra-c.com/forum/showpo...8&postcount=13 anyone know where I can find that software and what its called?

    3) Does anyone happen to know where the glow plug relay is located on the Signum?

    4) I seem to remember something about a manual way of reading the stored fault codes, something about flashing lights in the dash but cannot find it anywhere, was I dreaming or is there such a technique?

    5) Any pointers on what I need to connect my laptop to the car and read its codes?

    Thanks so much for your time guys, forums like this are godsend, especially when I cannot find any sort of manual for this car or engine.

  8. #8
    Regular Member
    Join Date
    May 2010
    Location
    Berkshuire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    gtr1000, I noticed your also in Berkshire, where abouts?

    I live in cippenham just on the west end of slough.

  9. #9
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri

    Engine : 140 Ecoflex S/S

    Year : 2013

    Default

    I'm between J4 of the M40 and Marlow with an SL postcode, not a HP one, basically South Bucks .

    In answer to your questions, the only one I can shed any light on is 1) - there ain't no manual available of any kind that covers this engine. For bodywork & running gear, the Haynes manual will suffice.
    Last edited by gtr1000; 17th January 2012 at 20:33.

  10. #10
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    How long have you had this car?

    The symptoms sound like the previous owner was low mileage and/or low speed, this is a very common cause of EGR failure and/or soot collection

    Take a look at the onboard computer and look at all the stats
    On mine the average speed is about 40mph

    It sounds like the mechanic was rather clueless and had never seen a 3.0 V6 CDTI or a diesel Vectra
    The glow plug relay should be on the nearside under the headlamp
    This is a stupid location for such a piece of equipment, directly under the washer bottle refill

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Now i think its the throttle body!! PLEASE HELP!
    By o9roberts in forum Vectra C / Signum Car Chat
    Replies: 23
    Last Post: 9th November 2010, 16:06
  2. Where is the Throttle body on 2.2 dti?
    By congaman in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 8th October 2010, 14:29
  3. Arrrr!Throttle my Throttle Body!
    By boze in forum Engine & Drivetrain
    Replies: 9
    Last Post: 12th September 2009, 11:15
  4. No throttle response on 3.0CDTi
    By Celes in forum Engine & Drivetrain
    Replies: 4
    Last Post: 26th July 2009, 10:35
  5. 3.2 throttle body
    By poves in forum How much is it worth? (THIS SECTION IS NOW CLOSED)
    Replies: 3
    Last Post: 15th December 2008, 10:16

Visitors found this page by searching for:

vectra 3.0 throttle body problems

vectra c 3.0 throttle body

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •