User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Cut out when driving hard

  1. #1
    Regular Member
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Cut out when driving hard

    Hope anyone can shed some light.

    I have a vectra c design 120 break 2007 model.

    For the last month or so I have noticed a slight judder when driving at low speeds. Almost as if the engine is skipping a heart beat. I bought some injector cleaner and that didnt make any difference at all.

    Last night I was in a hurry and drove it a bit harder than usual. I would say about 4000 revs per gear. When i got to 3rd gear and floored it, it cut out at about 4000 revs. The spanner light came on as well just before it cut out. I re-started the car and drove of with no problem.

    Again it died on me whilst driving it a bit hard.

    Any suggestions on this?

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Get the fault codes read

  3. #3
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by icecube10111 View Post
    When i got to 3rd gear and floored it, it cut out at about 4000 revs. The spanner light came on as well just before it cut out. I re-started the car and drove of with no problem
    Is it actually limiting the revs or completely shutting down?

    As above, give those symptoms to a garage and arrange code reading
    If it is happening every time that will make diagnosis easier

  4. #4
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    crank shaft speed sensor.

    bet it only happens when the engine is hot and feels like its going to stall at every junction.

    and heres a how to someone has already wrote.

    http://www.vectra-c.com/forum/showthread.php?t=150617

  5. #5
    Regular Member
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks to all for the feed back and suggestions.

    I bought myself a code reader and it came up with P0400. Judging by the numerous posts on this site, I am sure that all of you are familiar with the old EGR valve saga.

    I have taken the valve out and cleaned it the best I could.....O.M.G what a difference!!!!! I cant believe what the actual capabilities are of this engine, and what power it actually has.

    Anyway, I think although it definitely improved things, the valve is still knackered, because the code came up again, and I can still feel a little judder, especially when you let go of the accelerator to slag down for a stop.

    I am going to replace the valve. Can anyone please point me in the right direction to pay a reasonable price for the thing.....I am not going to the dealers, they will charge me a fortune.

    Thanks for any suggestions

  6. #6
    Regular Member
    Join Date
    Jun 2010
    Location
    bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks to all for the feed back and suggestions.

    I bought myself a code reader and it came up with P0400. Judging by the numerous posts on this site, I am sure that all of you are familiar with the old EGR valve saga.

    I have taken the valve out and cleaned it the best I could.....O.M.G what a difference!!!!! I cant believe what the actual capabilities are of this engine, and what power it actually has.

    Anyway, I think although it definitely improved things, the valve is still knackered, because the code came up again, and I can still feel a little judder, especially when you let go of the accelerator to slag down for a stop.

    I am going to replace the valve. Can anyone please point me in the right direction to pay a reasonable price for the thing.....I am not going to the dealers, they will charge me a fortune.

    Thanks for any suggestions

  7. #7
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    I have a good working one that I was going to put on ebay for £55 delivered if your interested.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spanner light while driving to work with no code and usually same point when driving to work?
    By rollercoaster63 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 6th July 2012, 21:52
  2. will this be hard or not
    By marc vectra sri in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 19th January 2012, 18:54
  3. Replies: 2
    Last Post: 28th July 2011, 13:37
  4. limp mode on motorway driving.....driving me crazy!
    By big rich in forum Diesel Engine related
    Replies: 25
    Last Post: 27th August 2010, 05:24
  5. AA driving school car + dangerous driving: Who to report to?
    By RSV_Ecosse in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 30th August 2007, 18:05

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •