User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: CIM fault - answers

  1. #1
    Regular Member taffy bhoy's Avatar
    Join Date
    Aug 2008
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CIM fault - answers

    not got the problem myself, but read plenty of posts about cim faults, what is it that actually fails? is it not something that can be repaired?

    just curious,

  2. #2
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    181 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    2 main problems I see with CIM, dials dropping dead and indicator cancelling too early before you turn... Not looked into the repairs yet, but suspect the indicator problem is due to some sort of opto-receiver when the wheel is turned..
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  3. #3
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    Or indicators dont cancelling.. (that have been the problems the 2 times i had mine replaced.. its due to faulty steering angel sensor)

  4. #4
    Regular Member MalcGSI's Avatar
    Join Date
    Mar 2006
    Location
    E Sussex & Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Or traction control and power steering light both on all the time.

  5. #5
    Full Member DSmiddy's Avatar
    Join Date
    Jul 2011
    Location
    Bridgwater, Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite

    Engine : 2.8 V6T

    Year : 2005

    Mileage : 50000

    Default

    Quote Originally Posted by MalcGSI View Post
    Or traction control and power steering light both on all the time.
    Thats what mine is doing well it was doing it when i got the car, any posts have i read people just replace the CIM.

    I know Simon opened his up and seem to find some dry joints so it might be to do with that, this was the post for it - http://www.vectra-c.com/forum/showthread.php?t=151139

  6. #6
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by MalcGSI View Post
    Or traction control and power steering light both on all the time
    That's the one I had
    Confirmed by putting an indicator on, not moving the steering wheel then cancelling it, but the light stays on

    It's just one of those components that fails and needs to be replaced

  7. #7
    Regular Member
    Join Date
    Nov 2011
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    seems a lot of cruise control faults could be CIM linked too.


    As we speak my car is at the vauxhall dealers while they fit a new CIM for me (just before xmas they changed the stalk and clutch pedal switch) so they're running out of cruise control system components to replace pretty fast

  8. #8
    Full Member DSmiddy's Avatar
    Join Date
    Jul 2011
    Location
    Bridgwater, Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite

    Engine : 2.8 V6T

    Year : 2005

    Mileage : 50000

    Default

    Quote Originally Posted by Betty View Post
    seems a lot of cruise control faults could be CIM linked too.


    As we speak my car is at the vauxhall dealers while they fit a new CIM for me (just before xmas they changed the stalk and clutch pedal switch) so they're running out of cruise control system components to replace pretty fast
    Dare I ask how much that is costing?

    Dave

  9. #9
    Regular Member
    Join Date
    Nov 2011
    Location
    Swindon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by SmidBro View Post
    Dare I ask how much that is costing?

    Dave

    I don't know, do you dare?


    The initial diagnosis, new stalk and new clutch switch with fitting and Tech 2 was £160 from Vauxhall

    The CIM and security passport, with fitting and Tech 2 was £490

    So a total of £650 to vauxhall. Plus the £50 or so the local car electric place charged to do the initial diagnosis of the fault as being a stalk issue.

  10. #10
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've had cruise control problems before and I would definitely recommend using come contact cleaner on the stalk and the CIM before going down the replacement CIM route. Mine is definitely a bad connection I would say.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Quiz questions and answers
    By Johnsdutton in forum Comedy & Humour
    Replies: 0
    Last Post: 10th May 2012, 20:52
  2. Right guys, I want answers.
    By R-ford_Vec_C in forum Troubleshooting
    Replies: 20
    Last Post: 4th October 2011, 08:23
  3. answers regarding HIDS and TECH 2
    By shaun260589 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 5th February 2010, 22:15
  4. lol - ebay questions and answers
    By poves in forum The 'Off Topic' room
    Replies: 14
    Last Post: 25th January 2009, 17:17
  5. Questions and Answers
    By Andy in forum Billing 2006 8/9th July
    Replies: 70
    Last Post: 4th July 2006, 08:35

Visitors found this page by searching for:

vectra c cim faults

how to clean cim on vectra sri

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •