User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Strange power boost

  1. #1
    Regular Member
    Join Date
    Nov 2010
    Location
    Maidstone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Strange power boost

    Does anyone else have this problem, when rising through the rev range to 2.5k i get this sudden but obvious boost of power, almost feels like a scooby glued to the rear bumper and giving it the beans. Any ideas?

  2. #2
    Regular Member bigdave1701's Avatar
    Join Date
    Apr 2010
    Location
    York
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Which engine?

  3. #3
    Regular Member
    Join Date
    Nov 2010
    Location
    Maidstone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry my mistake, its the 1.9cdti z19dth.

  4. #4
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    41 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    Er the turbo lol
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  5. #5
    Regular Member MrDerv's Avatar
    Join Date
    Nov 2011
    Location
    North East (Beamish)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Likely to be a split of hole in the pipe between the turbo vnt actuator and the actuator solenoid. Common issue as these little pipes perish and crack with age. Cheapest repair you'll ever make to your car

  6. #6
    Regular Member rockafella8587's Avatar
    Join Date
    Nov 2011
    Location
    Akrotiri, Cyprus
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by MrDerv View Post
    Likely to be a split of hole in the pipe between the turbo vnt actuator and the actuator solenoid. Common issue as these little pipes perish and crack with age. Cheapest repair you'll ever make to your car
    Eh, Are you answering some other thread here lol?

  7. #7
    Regular Member
    Join Date
    Nov 2010
    Location
    Maidstone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ive checked vacuum hoses and all seem fine, the other halfs cdti 120 seems to do the same, i guessed it was a common issue on the diesels.

  8. #8
    Regular Member MrDerv's Avatar
    Join Date
    Nov 2011
    Location
    North East (Beamish)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Next step would be EGR inspection and clean if necessary.

  9. #9
    Regular Member MrDerv's Avatar
    Join Date
    Nov 2011
    Location
    North East (Beamish)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by rockafella8587 View Post
    Eh, Are you answering some other thread here lol?

    Nope lol vacuum tubing is cheap as chips

  10. #10
    Regular Member rockafella8587's Avatar
    Join Date
    Nov 2011
    Location
    Akrotiri, Cyprus
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok now im lost lol, the op stated his problem was a sudden boost of power at 2.5k rpm, surely thats just normal when the turbo kicks in? A power loss on the other hand would be a problem!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. car running lumpy and now strange wooo sound when coming of boost??
    By richiem in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 4th June 2012, 13:00
  2. Help!! Power steering making strange noise
    By philgst in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 30th May 2011, 22:19
  3. no power off boost then savage boost at 2300rpm
    By 9tjc in forum Engine & Drivetrain
    Replies: 0
    Last Post: 2nd January 2010, 00:21
  4. strange noise when giving power
    By twaiter in forum Engine & Drivetrain
    Replies: 20
    Last Post: 25th October 2009, 00:39
  5. strange noise when turbo is on boost
    By Dave Mac in forum Engine & Drivetrain
    Replies: 7
    Last Post: 13th July 2008, 14:28

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •