User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Heated rear screen issues

  1. #1
    Regular Member Jonsey's Avatar
    Join Date
    Oct 2010
    Location
    Walkden, Manchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Heated rear screen issues

    Well on the drive home from work this evening I kept thinking the rear screen is taking ages to clear, you can see its on as it starts clearing on the lines, so thought just might be a one off, but just done a good 30 mile trip and same thing, had it on all the way there got out and felt the window but was cold, Thought might be a dodgy fuse but looks fine. Anyone got any ideas?


    Sent from my iPhone using Tapatalk

  2. #2
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    It tuens itself Off after 10 minuts

  3. #3
    Regular Member Jonsey's Avatar
    Join Date
    Oct 2010
    Location
    Walkden, Manchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I kept turning it back on once it went off, usually its clear after 5-7mins


    Sent from my iPhone using Tapatalk

  4. #4
    Full Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check the fuse that it isnt blown

  5. #5
    Regular Member Jonsey's Avatar
    Join Date
    Oct 2010
    Location
    Walkden, Manchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Fuse is fine


    Sent from my iPhone using Tapatalk

  6. #6
    Regular Member
    Join Date
    Oct 2011
    Location
    Essex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    How clean is the inside of the screen? Give it a proper polish, see if that helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Elite Estate Rear Heated Screen
    By keefy*2010 in forum Styling
    Replies: 5
    Last Post: 27th June 2011, 15:29
  2. heated rear screen
    By gary_e in forum Troubleshooting
    Replies: 0
    Last Post: 16th November 2010, 00:01
  3. Rear Heated Screen Fault
    By BaileySRI in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 9th February 2010, 09:25
  4. Heated screen
    By shadow in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 12th December 2009, 20:38
  5. Heated rear screen element repair
    By Vecmaniac in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 20th January 2008, 09:22

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •