User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Intermitent low down power loss

  1. #1
    Regular Member
    Join Date
    Sep 2011
    Location
    West Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Intermitent low down power loss

    Hi Guys, I have been experiencing an intermitent loss of power low down (1500-2000 rpm) on my 06 120 diesel veccy anything above 2000rpm, once turbo kicks in, and it goes like a train. It seem more obvious when cold but is still there but too a lesser degree when warm. I haven't had chance to look at anything just yet, planning a bit of diagnostic work over the weekend, just need a few pointers. Gonna check and clean EGR, gonna check vac pipes....

    anything else I should be looking at??

  2. #2
    Regular Member
    Join Date
    Oct 2008
    Location
    Reading
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Boost pressure sensor maybe?
    Had a similar issue on my 150, changed the sensor, all good again.
    good luck
    Cheers
    Mark

  3. #3
    Regular Member
    Join Date
    Sep 2011
    Location
    West Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by 137mph View Post
    Boost pressure sensor maybe?
    Had a similar issue on my 150, changed the sensor, all good again.
    good luck
    Cheers
    Mark

    Thanks I'll give it a look see, give it a clean while EGR is off as it's a bu66er to get to from what I've read with EGR insitu

  4. #4
    Regular Member
    Join Date
    Sep 2011
    Location
    West Mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    So got home today and decided to have a go at cleaning EGR valve with a lot of help from the 'How 2' guide and found it to be an easy task and well worth doing as the thing was well tight. Moves nice and freely now. Also took 137mph's advice and whipped out the boost pressure sensor, another worth while task as it was thick with sooty sludge. 10 minutes soaking in carb cleaner and a gently brushing down with one of the kids paint brushes and it was nice and clean again.
    The upshot of these two simple tasks is that the veccy is back to it's good old self with nice smooth power and great throttle response.

    Bodgers 1-0 Stealers

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. loss of power
    By rick1965 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 17th October 2010, 15:54
  3. Loss of POWER!!!!!!!!!!
    By dan1983 in forum Engine & Drivetrain
    Replies: 11
    Last Post: 11th June 2009, 07:48
  4. Loss of power
    By rob123 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 13th May 2008, 18:22
  5. Power Loss
    By Rem in forum Engine & Drivetrain
    Replies: 2
    Last Post: 29th March 2008, 20:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •