User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Abs warning light

  1. #1
    Regular Member Ben R's Avatar
    Join Date
    Jul 2011
    Location
    Southampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Red face Abs warning light

    My ABS warning light has started coming on intermittantly with no real pattern as to when and why. Is this some sort of brake pads low warning as well or am I about to have big problems?

  2. #2
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    Could just be a dirty connection on the plug on the wheel hubs or on the ABS pump under the bonnet.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  3. #3
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When it comes on, how long for?
    Does it go out from engine start, then come on and stay on?

    Brake pad warning will be the brake / handbrake warning light or the warning in the rev counter, so it's not that

  4. #4
    Regular Member Ben R's Avatar
    Join Date
    Jul 2011
    Location
    Southampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It seems to come on from engine start and stays on until I stop. The next journey it might not come on at all. Thats why I wondered if it was done sort of sensor problem or a loose connection somewhere. There are no other adverse affects although I haven't tried to activate the ABS while driving for obvious reasons.

  5. #5
    New Member
    Join Date
    Jan 2012
    Location
    Ripon North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Ben, it is my first time on this Forum, so forgive me if i am not answering in the correct place, and it is 15 days later, i had the same problem with my Vectra 06 1.9cdti 120 bhp i was told by a mechanic that it was probably my front passenger side wheel hub needing replacing without even looking at it. i put it off for a while as it was intermittent. recently i changed my suspension front and rear, put it back to original height, and my abs light was on permanently i took it to an auto electrician and i was charged £50 for them to tell me that it was my front passenger wheel hub assembly needs replacing, apparently this is a common fault in the vectras.

  6. #6
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Was it the hub, or was it the wiring that was actually at fault?

    There is a electrical connector on the suspension leg and it gets water in sometimes and cause electrical issues.

    If it was intermittent, then I cannot think of a failure mode in the speed ring that could be the cause.

    Maybe dislodging this connector caused it to come on all the time? Often times simply disconnecting it and reconnecting a few times will clean the corrosion and make electrical contact again. Maybe a spray of contact cleaner or WD40 too, and drying the connector internals.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warning Light
    By chrissy white85 in forum Troubleshooting
    Replies: 7
    Last Post: 17th December 2012, 18:01
  2. Brake Light Warning Light
    By michaelangelo in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 29th August 2011, 01:31
  3. Spanner light & 3rd brake light warning?
    By simp_2.2sri in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 5th December 2008, 17:32
  4. Oil Warning Light
    By siz1 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 26th November 2008, 20:03
  5. arghh side light problems warning light
    By Gregg in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 11th February 2008, 21:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •