User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Two questions

  1. #1
    Regular Member
    Join Date
    Dec 2011
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Two questions

    Hi all.

    After washing and polishing my new toy, Ive noticed on the two front alloys that a small amount of lacquer has began to flake off the silver under paint. Not a great deal i must say tho. Is there a quick fix i can undertake before more radical work is needed ? ( the siver paint is still in good order )

    My other question is ...there are loads of different hand polishes on the market. What do you guys use...and what do you guys suggest to give my paint work, above all the best protection, and of course a lovely shine .

    Many thanks people in advance.

    Dave.

  2. #2
    Regular Member Ginge7289's Avatar
    Join Date
    Jan 2011
    Location
    Woodbridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like your wheels have been cleaned with a acid wheel cleaner and it has been left on too long or not rinsed off correctly. For both, Wax is the answer to your problem. Polish does not protect your car, Wax protects it.

    Have a read of the detailing section and look at some of the posts in there.

  3. #3
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    when I first started detailing I used autoglym srp and autoglym extra protection sealent after srp now I use collinate wax much better for a show room shine

    Also don't use acid wheel clear ie wonder wheels use a none acid wheel cleaner

  4. #4
    Regular Member
    Join Date
    Dec 2011
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by marc vectra sri View Post
    when I first started detailing I used autoglym srp and autoglym extra protection sealent after srp now I use collinate wax much better for a show room shine

    Also don't use acid wheel clear ie wonder wheels use a none acid wheel cleaner
    Hi. Were do i get that from ?

  5. #5
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    Wheel cleaner got it from autobrite mate wax from eBay polish from halfords

    Wax is collinite 476s bout 13 ebay
    Can get wheel cleaner there too bilberry its called
    Last edited by marc vectra sri; 8th January 2012 at 00:29.

  6. #6
    Regular Member
    Join Date
    Dec 2011
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Ginge7289 View Post
    Sounds like your wheels have been cleaned with a acid wheel cleaner and it has been left on too long or not rinsed off correctly. For both, Wax is the answer to your problem. Polish does not protect your car, Wax protects it.

    Have a read of the detailing section and look at some of the posts in there.
    Many thanks to you both...when you say detailing section...is within the forum menus ?

  7. #7
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    Yer its half way down the forum

  8. #8
    Regular Member Ginge7289's Avatar
    Join Date
    Jan 2011
    Location
    Woodbridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HID questions
    By Angel1368 in forum Styling
    Replies: 20
    Last Post: 9th May 2012, 11:08
  2. A few questions!
    By mishima in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 15th October 2009, 21:38
  3. A few questions.......
    By mc_orion in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 5th August 2007, 17:18
  4. Just a few questions ;)
    By BlueRob in forum Petrol Engine related
    Replies: 5
    Last Post: 24th July 2007, 04:30
  5. Questions !!!
    By zubs187 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 9th July 2007, 17:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •