User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47

Thread: twang when turning steering

  1. #1
    Full Member coldo's Avatar
    Join Date
    May 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default twang when turning steering

    Right... bit of a confusing one here...

    the car developed a "twang" "clunking" sound at the begingin of december. Diagnosis was either a broken spring or a worn top mount for the suspension.

    So two new top mounts and a set of Eibachs where ordered and fitted and the noise seemend to go away 90% of the time. Just an ocasions sound when I drove off inthe morning turning the wheel to pull out the drive. I put this down to cold parts etc.

    Anyway. Today, driving to work I noticed when turning the wheel the twang noise is back on the passenger side (where it was comming from before)... girr....

    when the springs and top mounts were swaped out we checked the drop links and all seemed sound with no movement etc.

    From reading previous posts people have put up I am not sure if i should be looking at the drop links and ARB Bushes as another possible area for this noise...

    To be clear... the symptoms are worst when the car is stationary and I turn the wheel in either direction. It sounds like a twang, creeking sound and is from the passenger side of the car.

    So what do you guys recon it could be....?

  2. #2
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    broken spring

  3. #3
    Full Member coldo's Avatar
    Join Date
    May 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bembo449 View Post
    broken spring
    Checked the springs (brand new eibachs) and they are sound...

    I changed the full top mount part of the suspension when I swaped the springs out. I assumed this also included the top mount bearing as a complete part... is that right...?

  4. #4
    Vectra-C Obsessed Poster Drinky's Avatar
    Join Date
    Jun 2005
    Location
    on your momma !!!!!!!!!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    When you fitted the new springs did you fit the silicone sleeve over the bottom coil of the new spring ????

    If not my guess is it needs these fitting

    Back in a V6 !!!!!!!!!!!! And lovin it !!!

  5. #5
    Full Member coldo's Avatar
    Join Date
    May 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Drinky View Post
    When you fitted the new springs did you fit the silicone sleeve over the bottom coil of the new spring ????

    If not my guess is it needs these fitting
    Yep... fitted the sleave to the bottom of the spring... and ensured it was seated properly in the cup...

    As I only get it when turning the wheel i am assuming the drop link and ARB bush is not to fault.

  6. #6
    Vectra-C Obsessed Poster Drinky's Avatar
    Join Date
    Jun 2005
    Location
    on your momma !!!!!!!!!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Very unlikely to be the ARB bushes as they only rattle when going over broken ground
    Same with the Drop links to be honest !!!!

    The strut top and bearing are seperate parts so unless you replaced all 4 parts i would say the bearing has collapsed and is dragging the spring round the strut insert when you turn the wheel

    Back in a V6 !!!!!!!!!!!! And lovin it !!!

  7. #7
    Full Member coldo's Avatar
    Join Date
    May 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Drinky View Post
    Very unlikely to be the ARB bushes as they only rattle when going over broken ground
    Same with the Drop links to be honest !!!!

    The strut top and bearing are seperate parts so unless you replaced all 4 parts i would say the bearing has collapsed and is dragging the spring round the strut insert when you turn the wheel
    Are they...?

    My neighbour (who works for kwikfit) got me them. It was a complete part which we swaped out on the spring assembly. There was not other parts other than the nut at the top of the spring if that makes sence.

  8. #8
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by coldo View Post
    Checked the springs (brand new eibachs) and they are sound...

    I changed the full top mount part of the suspension when I swaped the springs out. I assumed this also included the top mount bearing as a complete part... is that right...?
    it will defo be spring related , are you 100% positive the tops were tight after fitting the Eibachs , from experience i know if they arent you will get this as the springs move around in the seats

  9. #9
    Full Member coldo's Avatar
    Join Date
    May 2010
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeah... we tightened them up with an impact wrench.... they were solid...

    Tonight I am going to check the following...

    Sring cup (lower) for stones etc traped.
    The strut top nut (incase it is loose)
    check if the strut top is catching on the torque screws (unlikley but worth checking)
    Photo's of the lot to ensure the bearing kit is there...

    On the bearing kit... is it possible to fit the suspension back together securly without these being there?

    Does anyone have the part number / description for these on euro car parts?

  10. #10
    Regular Member
    Join Date
    Jan 2011
    Location
    lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by coldo View Post
    yeah... we tightened them up with an impact wrench.... they were solid...

    Tonight I am going to check the following...

    Sring cup (lower) for stones etc traped.
    The strut top nut (incase it is loose)
    check if the strut top is catching on the torque screws (unlikley but worth checking)
    Photo's of the lot to ensure the bearing kit is there...

    On the bearing kit... is it possible to fit the suspension back together securly without these being there?

    Does anyone have the part number / description for these on euro car parts?
    ok , its just occured to me that on occasion when i'd lowered my old gsi I got a very similar problem , it would last for a few miles then fall silent again ! never did find out what the hell it was bud

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. twang twang BANG !
    By gsxrster in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 11th March 2012, 21:27
  2. Clunking when turning steering?
    By Thom in forum Suspension, Wheels & Brakes
    Replies: 7
    Last Post: 16th January 2012, 01:42
  3. Steering Juddering when stationary & turning wheel
    By jsr645 in forum Suspension, Wheels & Brakes
    Replies: 19
    Last Post: 1st February 2011, 17:35
  4. Knocking when turning steering to the right
    By Dippy-Vx-line Red in forum Engine & Drivetrain
    Replies: 8
    Last Post: 24th February 2010, 21:32
  5. Flickering display when turning steering wheel
    By sharpo in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 17th July 2009, 08:59

Visitors found this page by searching for:

steering twang car

vectra c spring noise when turning steering wheel

vectra c twang turn wheel

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •