User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Poor MPG

  1. #1
    Regular Member !tf's Avatar
    Join Date
    Apr 2011
    Location
    Chesterfield/Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Poor MPG

    I noticed my mpg had dropped to around 38-40 the other week.i used to get 45-55 easily even with a heavy right foot. Cleaned out the EGR valve as it was filthy and im still getting the same results. I replaced the thermostat around six months ago and i have noticed the temperature guage is dropping again when the heaters are on. Its dropping to around 78-80 degrees.

    Should i be replacing the thermostat again? is there anything else i should be looking into to try and improve my MPG?

    Also how would i know the car has a fault with a fault code reader? Do lights flash up on the dashboard? Car is a 2004 1.9cdti 150.

  2. #2
    Regular Member !tf's Avatar
    Join Date
    Apr 2011
    Location
    Chesterfield/Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    without a fault code reader even.

  3. #3
    Vectra-C Obsessed Poster Drinky's Avatar
    Join Date
    Jun 2005
    Location
    on your momma !!!!!!!!!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The engine temp will always drop when you put the heater on as the heater matrix acts like another radiator and cools the engine down a small amount ...............Also dont forget most engine will always run slightly cooler in the winter !!!

    As for fuel consumption ............Could be time to look at the inlet manifold as that may be getting clogged up with soot hence resticting the airflow !!!

    Back in a V6 !!!!!!!!!!!! And lovin it !!!

  4. #4
    Regular Member !tf's Avatar
    Join Date
    Apr 2011
    Location
    Chesterfield/Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I cleaned what i could of the inlet manifold when i cdleaned the EGR the other night. Would swirl valve problems be worth looking into?

  5. #5
    Regular Member !tf's Avatar
    Join Date
    Apr 2011
    Location
    Chesterfield/Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just check the swirl valves and the rod seems loose but all four are moving when the engine is on. Is this somthing to worry about.


    ---
    I am here: [ame="http://maps.google.com/maps?ll=53.369894,-1.226580"]Google Maps[/ame]

  6. #6
    Regular Member Toe-side's Avatar
    Join Date
    Dec 2011
    Location
    Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Are you also loosing Power?
    I cleaned My EGR, as the How to and checked that the solenoid was free to move but shortly after I started to loose power at low revs again and fuel consumption was dropping. I Blanked the EGR (Using the gasket as a template I made a blanking plate) to basically see if the problem cleared......... and it did.
    Power and fuel consumption back to normal. Its a quick check to try and diagnose whether the EGR is at fault.

  7. #7
    Regular Member !tf's Avatar
    Join Date
    Apr 2011
    Location
    Chesterfield/Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Performance is fine. Still pulls like a train.


    ---
    I am here: [ame="http://maps.google.com/maps?ll=53.278185,-1.273647"]Google Maps[/ame]

  8. #8
    Regular Member
    Join Date
    Dec 2009
    Location
    exeter
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine the same 188 miles to 22ltrs of fuel which i have worked out to be 38 mpg and mine is a dti . i also done the egr and inlet still no better. im going to try a new fuel filter and see if that helps . does anyone else have any idea's what it could be . i'm not heavy with my foot . when i frist got it it was doing 300+ to half a tank now i'm getting 200 ish
    Last edited by reeseandellie; 7th January 2012 at 12:32.

  9. #9
    Regular Member
    Join Date
    Jun 2011
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    when was the last time you changed your air filter also ?

  10. #10
    Regular Member
    Join Date
    Dec 2009
    Location
    exeter
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    well when i had it seviced and they said it was ok . it was about 6 months ago . but they did tell me that my pollen filter was fine . but when i looked a month ago it was choked up with crap . so i dont know if i can beleave if he has done any of it

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What have they done to my poor car?!
    By DNS in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 27th November 2011, 19:55
  2. My poor poor veccy :(
    By tammyman09 in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 9th June 2011, 10:46
  3. Would You Say This Is Poor MPG?
    By Si-SRI in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 7th February 2010, 00:06
  4. Nooooooo!!!!, my poor, poor car!!
    By Duncan in forum Vectra C / Signum Car Chat
    Replies: 208
    Last Post: 11th May 2006, 16:32
  5. My Poor Poor Signum
    By Brake buster in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 30th September 2005, 15:45

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •