User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: P0380 Code

  1. #1
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default P0380 Code

    As been discussed previously, this code was present in my CDTi 150, had the glow plugs changed and code cleared.

    The spanner light has re-appeared but goes out once started which I believe is not the norm but acceptable.

    My point being glow plugs have been changed and spanner light has re-appeared, what is could it be?




    Thanks

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Was the code defiantly cleared as once a code has been set and the fault fixed the light will still come on at engine start and then go straight off.

    I would get the codes read/cleared again.

  3. #3
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    When I first picked the car up today and drove it home the spanner light when out before I started the engine.

    When to go back out earlier and the spanner light remained on until the engine was started

  4. #4
    Regular Member
    Join Date
    Feb 2011
    Location
    grimsby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi there mate i have the same fault on mine. It starts perfect every time and first thing in morning spanner light will be on for approx 2 minutes. I have Opcom and used to keep clearing fault codes but have just got used to it now. I have been told that something goes wrong with the glow plug relay but as they are working am reluctant to change it

  5. #5
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    The code P0380 was read again and informed it was "Device Circuit General Error".

    Any ideas on what this is?


    Cheers

  6. #6
    Regular Member gtr1000's Avatar
    Join Date
    Dec 2007
    Location
    Carmarthen
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri

    Engine : 140 Ecoflex S/S

    Year : 2013

    Default

    Quote Originally Posted by Sebastian B View Post
    The code P0380 was read again and informed it was "Device Circuit General Error".

    Any ideas on what this is?


    Cheers
    Taken from another site - "P0380 Glow Plug/Heater Circuit "A" Malfunction".

  7. #7
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    Quote Originally Posted by gtr1000 View Post
    Taken from another site - "P0380 Glow Plug/Heater Circuit "A" Malfunction".
    Confused?

    Me also

  8. #8
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    Anybody else got any ideas on this?

  9. #9
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    From another site:

    Possible causes

    - Glow Plug harness is open or shorted
    - Glow Plug circuit poor electrical connection
    - Faulty Glow Plug

  10. #10
    Regular Member WeDesign's Avatar
    Join Date
    Jun 2006
    Location
    Vectra-C.com
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : CDTi 150

    Year : 55

    Default

    Had the code cleared again, lets see what it brings up again.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help error code P0380
    By tomo610 in forum Troubleshooting
    Replies: 7
    Last Post: 30th June 2012, 20:57
  2. P0380 Fault Code
    By fattony in forum Engine & Drivetrain
    Replies: 9
    Last Post: 12th December 2011, 01:15
  3. FAULT CODE HELP: p0380-08 glow device general error
    By merikiito in forum Engine & Drivetrain
    Replies: 4
    Last Post: 19th November 2011, 17:28
  4. Code p0380, how do you find faults in glow circuit?
    By Gazza36 in forum Engine & Drivetrain
    Replies: 14
    Last Post: 4th February 2011, 14:02
  5. P0380 fault code
    By frag45 in forum Troubleshooting
    Replies: 6
    Last Post: 15th December 2010, 09:15

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •