User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Lights failed on instrument panel

  1. #1
    New Member
    Join Date
    Dec 2011
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Lights failed on instrument panel

    Hi All,

    I hope you can help me.

    The dashboard illumination recently failed on my Vectra.

    Specifically: the instrument panel (i.e. where the speedo, rev counter, ect are) and the heater/ventilation area.

    The illumination on the headlight control console, to the right of the steering wheel (which, ironically, includes the illumination ‘dimmer’ control – which works correctly, incidentally) is working fine, as is the illumination on both the electric window consoles on both doors.

    I was hoping this would simply be a fuse, but a quick look at the fuse diagram doesn’t make it clear whether a specific fuse protects this system.

    Fuse 17 is listed as “Instruments, information display” – 15A, but fuse 26 is also labelled as “Instruments, information display” though with only a 7.5A fuse. Regardless, neither seems to have blown.

    Can anyone tell me which fuse protects the dash illumination?

    Or can anyone give me any advice on fixing my little problem.

    Thanks in advance.

    Graham.

  2. #2
    New Member
    Join Date
    Jan 2012
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy Dash lights

    Hi Graham,
    Just wondering whether you managed to get your dashboard lights working as i now seem to have the same problem

    Regards

    Rob

  3. #3
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    had this on mine, the fuse 17 wasn't blown but I had to re-seat it to get them to work

  4. #4
    Regular Member tramman's Avatar
    Join Date
    Jul 2007
    Location
    Selby, North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default



    Just pop out fuse and reseat had this on mine about a week ago. Can't find any cause or reason for it to happen tho.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Instrument panel
    By copperkettle in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 7th June 2012, 15:02
  2. VXR instrument panel?
    By the_rocker in forum Styling
    Replies: 11
    Last Post: 17th April 2012, 12:19
  3. Instrument Panel Lighting
    By dc6839 in forum Bodywork & Interior
    Replies: 1
    Last Post: 29th July 2010, 12:17
  4. Instrument Panel dials lit when external lights off
    By Street N in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 15th January 2009, 23:26
  5. Insignia Instrument Panel.
    By Maverick in forum Insignia car chat
    Replies: 15
    Last Post: 7th June 2008, 13:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •