User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Diagnostics scanner

  1. #1
    Regular Member
    Join Date
    Jun 2010
    Location
    bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Diagnostics scanner

    Hi All.

    First of all, I hope you all had a lovely Christmas.

    I have a Vectra C Design 120BHP. (2007)

    Lately I had the spanner light come on and the car went into lump mode. After I re started the car it was fine. Last night the Exhaust emmisions light came on, and the car just died on me whilst driving, almost like the diesel supply was cut. Restarted the car, and all went fine, however the light is still on.

    I now have a Maxiscan MS509 OBD2/EOBD reader, however when I plug it in the scanner is saying that the car is not communicating. Can anyone please advise if I am doing something wrong?

    Regards

  2. #2
    Regular Member disco dan's Avatar
    Join Date
    Apr 2011
    Location
    Southport
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    does the pedal test work?

  3. #3
    Regular Member J's Turbo's Avatar
    Join Date
    Sep 2011
    Location
    luton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by icecube10111 View Post
    Hi All.

    First of all, I hope you all had a lovely Christmas.

    I have a Vectra C Design 120BHP. (2007)

    Lately I had the spanner light come on and the car went into lump mode. After I re started the car it was fine. Last night the Exhaust emmisions light came on, and the car just died on me whilst driving, almost like the diesel supply was cut. Restarted the car, and all went fine, however the light is still on.

    I now have a Maxiscan MS509 OBD2/EOBD reader, however when I plug it in the scanner is saying that the car is not communicating. Can anyone please advise if I am doing something wrong?

    Regards
    Are you leaving the ignition on?

  4. #4
    Regular Member
    Join Date
    Jun 2010
    Location
    bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi.

    Have tried the pedal trick, and my car does not seem to flash anything on the dasboard.

    Here is what I did with the scanner.

    1) Plug it in the plug underneath the ashtray (I asumed this is the correct plug)
    2) Turn on ignition, so that all lights come on.
    3) Start diagnostics on the scanner, and the scanner stops halfway, saying there is a problem with the connection.

    Am I using the correct plug?

  5. #5
    Regular Member MrDerv's Avatar
    Join Date
    Nov 2011
    Location
    North East (Beamish)
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    What communication protocol is the reader set to?

  6. #6
    Regular Member
    Join Date
    Jun 2010
    Location
    bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Not sure.

    I dont think you can set the protocol, because when you plug it in and ask for it to diagnose, it seems like it is running trough all the protocols that it knows, but doesnt seem to have one that this Vectra model is programmed to.

    Im beginning to think that the Maxiscan MS509 does not have the required protocol installed? I might be wrong.

    Do you by any chance know what the protocol for this model would be, and if there are any recomended software that I can get for my laptop to read it with.

    Thanks in advance

  7. #7
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    maybe the lead is faulty... my ms509 connects and reads my 06 cdti 16v no bother

  8. #8
    Regular Member
    Join Date
    Jun 2010
    Location
    bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    That is my thought as well at this stage to be honest.

    However I have been doing some research, and found that apparantly the newer model cars comes out with a CAN-BUS protocol. And that you need to have a scanner that is able to read this protocol. That still leaves me in the dark because.

    1) I am not sure that my car would have come out with this protocol it being only one year younger than yours.
    2) I am not sure if the MS509 can read CAN-BUS protocols or not.

    I found a scanner on e-bay that will read all protocol including the "latest" CAN protocol. I will order now, and if it works will deffinitly share the outcome, that might be usefull for any other 2007 Vectra owners.

    In the mean time if anyone can confirm the protocol I will appreciate.

  9. #9
    Full Member
    Join Date
    Dec 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Your scanner will do canbus

  10. #10
    Full Member
    Join Date
    Dec 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Plug scanner in
    Turn on scanner
    Turn on ignition when scanner prompts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Diagnostics
    By rmg1 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 21st June 2012, 03:08
  2. Diagnostics
    By neill in forum North West (RO - Paulvectrac )
    Replies: 0
    Last Post: 10th April 2012, 19:55
  3. Rac Diagnostics Scanner
    By Paulrushton in forum Troubleshooting
    Replies: 0
    Last Post: 26th July 2010, 11:41
  4. Code Reader / Diagnostics Scanner
    By r.bailey63 in forum North East RO Vacant - ARO - Vacant
    Replies: 3
    Last Post: 4th March 2010, 10:34

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •