User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Av MPG dropping badly!!!

  1. #1
    Regular Member
    Join Date
    Jun 2009
    Location
    Chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Av MPG dropping badly!!!

    Cars a 05 1.9cdti sri, its been averaging 50+ mpg on screen display, recently had an injector seal go and mpg went down to around 42, seal was replaced and everything ok again back up to 50+, now over the last two days its dropped to around 42mpg, checked the injectors and they dont seem to be blowing, any ideas as to why the sudden drop in mpg, nothing changed in my driving!!

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    42 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Egr clogged up.
    Swirl bar broken due to inlet manifold being clogged up.

  3. #3
    Regular Member
    Join Date
    Jun 2009
    Location
    Chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    its got a new uprated swirl bar & Egr only 14 months ago!

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    42 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    How many miles have you done in that time?

  5. #5
    Regular Member
    Join Date
    Jun 2009
    Location
    Chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    prob less than 10000

  6. #6
    Regular Member Danger_MouseUK's Avatar
    Join Date
    Jan 2010
    Location
    Merseyside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Out of curiosity, what did you pay to have your injector seals replaced?

  7. #7
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Does the car warm to 86ish degrese on the gauge?

  8. #8
    Regular Member amand's Avatar
    Join Date
    Feb 2011
    Location
    west London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could be thermostat, as AntSSSS says, does it get warm?

  9. #9
    Regular Member
    Join Date
    Jun 2009
    Location
    Chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    All ok again now, back up to 48/50 avg, Thermostat working ok its a new one, Could have been down to injector seal???
    Out of curiosity, what did you pay to have your injector seals replaced?
    I paid £1.50 for the seals, i did it myself easy job, injector took a bit of time to move as it was carboned up with the crap from the leaking seal, but all done in 30 min.

  10. #10
    Regular Member Danger_MouseUK's Avatar
    Join Date
    Jan 2010
    Location
    Merseyside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Governor View Post
    All ok again now, back up to 48/50 avg, Thermostat working ok its a new one, Could have been down to injector seal???


    I paid £1.50 for the seals, i did it myself easy job, injector took a bit of time to move as it was carboned up with the crap from the leaking seal, but all done in 30 min.
    Yeah i was going to do my own as well, bought all the seals, nuts and cup washers, but can i b*gg*r shift the injectors, they are well and truly stuck in place, even after a few very liberal bursts of engine deblock oil. So I was wondering how much i'd be looking at to get two seals replaced by pro's to save me doing more damage than good.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Creaking badly
    By marc vectra sri in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 9th June 2012, 16:25
  2. Badly need advice or help!
    By Hendry02 in forum General Chat
    Replies: 3
    Last Post: 16th December 2010, 01:42
  3. i want one so badly i might cry!!
    By vectra_c_wannabe in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 2nd July 2010, 19:59
  4. need help badly
    By keith_johnson1967 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 31st March 2010, 17:15
  5. struggling badly
    By pogo in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 9th May 2006, 19:06

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •