User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: 2.0 DTi rubbish morning starts

  1. #1
    Regular Member
    Join Date
    Feb 2011
    Location
    Uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 DTi rubbish morning starts

    Hi - I have been looking through the forum for a while now and havent been able to find a credible fix for the cr@p morning starts on the Vectra-C's. I wonder if anyone can help before the car has an 'unexplained engine fire'

    So - The car wont start when its cold - I dont think it is a injector seal issue as if i unplug the coolant temp sensor (which forces the glow plugs on) it starts up ok. I also get the P0380 error (even when the coolant sensor is connected)

    I have changed the following :- glow plugs (twice), Coolant temp sensor (twice), glow plug relay and for some reason my mechanic suggested the crankshaft sensor

    Still got the rubbish light coming on and its still a pain in the ar5e to start.

    I have found the following article on the P0380 error on the website Permoveo (http://www.permoveo.ltd.uk/tabid/122...l/Default.aspx), this talks about the ECU being boned...

    Generic OBD Error Code Details for P0380


    Glow Plug/Heater Circuit "A"


    What does this mean?

    OBD Code P0380refers to
    The optical sensor provides a high resolution signal to the Powertrain Control Module (PCM) by counting pulses on the sensor disk located in the injection pump. The high resolution is one of the most important inputs by the PCM for fuel control and timing. This test monitors the number of high resolution pulses which have been missed (not detected). It's based on a comparison between the number of pulses that were detected since the last pump cam pulse and the number of the pulses that should have occurred. There are approximately 64 high resolution pulses for every cam pulse.
    Symptoms

    Possible sumptoms of OBD code P0380
    - Engine Light ON (or Service Engine Soon Warning Light)
    Causes

    Possible causes of OBD code P0380
    - Open or short in the optical sensor circuit - Optical sensor connector - Damaged optical sensor - Damaged PCM or ECM The Error code is generally activated on detection of the following conditions: Some high resolution pulses are missing from the optical sensor to the PCM
    Possible Solutions

    - If damage, repair optical sensor circuit - Replaced optical sensor - Replaced PCM or ECM



    Has anybody got ANY idea what they are going on about as its all spanish to me (no offence intended) or has anybody managed to fix a bad starting Vectra ??

    Sorry for the extended essay

  2. #2
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mokka

    Trim : SE - Orange Rock 's !!

    Engine : 1.7CDTi

    Year : 2014

    Default

    Have you actually checked the glow plugs in case any are open circuit???

  3. #3
    Regular Member
    Join Date
    Feb 2011
    Location
    Uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah - Checked all the plugs and they are fine...

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Is there not an ECU software update for the 2.0 DTi's, for this problem?

  5. #5
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : ELITE

    Trim : FULL LEATHER

    Engine : 1.9 CDTI 150 BHP

    Year : 2004

    Mileage : 87,000

    Default

    have you tried a new battery i changed mine and it is much better , i also put a switch inside the car for the engine temp switch for back up

  6. #6
    Regular Member
    Join Date
    Feb 2011
    Location
    Uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The car went in to the stealers and they done some diags, no leaks from the injector seals, an ECU remap (and a handbrake ratchet upgrade), was a little better starting and the glow lamp came on a more often but now back to plop again... Fitted a button on the dash to get the damn thing started but want to fix it properly...

    New battery tomorrow i think... Will let you know how i get on

  7. #7
    Regular Member
    Join Date
    Feb 2011
    Location
    Uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    One thing I did notice when i changed the plugs was that the threads on a couple of the plugs had been chewed up, i didnt change the first set so didn't know. Could this cause a bad earth ? Is it possible to 're-fresh' the thread with head in place....

    The general resistance across the plugs are 0.9 ohms

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Morning starts are ok - Afternoon starts are a ******!
    By Madaxeman in forum Vectra C / Signum Troubleshooting
    Replies: 18
    Last Post: 28th February 2011, 19:38
  2. And so it starts
    By chrisg in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 31st December 2010, 14:55
  3. It starts...
    By ClarCE in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 17th October 2007, 20:09
  4. Is this how it starts..
    By John35 in forum Styling
    Replies: 16
    Last Post: 30th June 2007, 08:52

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •