User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Massive flat spot between 1-2k revs vec c cdti 150

  1. #1
    New Member
    Join Date
    Dec 2011
    Location
    Cumbria
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Massive flat spot between 1-2k revs vec c cdti 150

    Massive flat spot between 1-2k revs after 2k pulls like a train, changed the fuel filter and cleaned the boost sensor still same any ideas??

  2. #2
    Regular Member shb1988's Avatar
    Join Date
    Oct 2010
    Location
    sittingbourne
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Default

    Egr valve maybe? Remove and clean up as they are prone to getting clogged

  3. #3
    New Member
    Join Date
    Dec 2011
    Location
    Cumbria
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I'll have a look tomorrow

  4. #4
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Normal ain't it on the cdti 150 mine is the same turbo lag

  5. #5
    Regular Member Ginge7289's Avatar
    Join Date
    Jan 2011
    Location
    Woodbridge
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    have you checked the vac hoses for splits?

  6. #6
    Regular Member Hideous's Avatar
    Join Date
    Mar 2007
    Location
    GB
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    should be pulling fully from about 1700rpm.
    as mentioned, could be the first signs of some egr trouble.
    you can clean it to try - but sometimes it's just better to get a new one. don't go to main dealer for this, it's daylight robbery from there.
    you can get a new one on ebay for £90 - simple diy job to remove and refit; takes 10 minutes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CDTI 150 Dreaded flat spot HELP!!!
    By keets in forum Engine & Drivetrain
    Replies: 11
    Last Post: 19th October 2015, 09:26
  2. 1.9 cdti 120 poor mpg and flat spot at low revs
    By mattclayt in forum Engine & Drivetrain
    Replies: 6
    Last Post: 17th January 2013, 23:36
  3. CDTi-150 Flat Spot @ 1800rpm
    By Signum7060 in forum Troubleshooting
    Replies: 12
    Last Post: 30th July 2012, 07:27
  4. Could this be the cause of 1.9 cdti 150 flat spot?
    By andreitone in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd November 2011, 18:00
  5. CDTI 150, more FLAT SPOT HELP please!
    By Vaux-Man-G in forum Engine & Drivetrain
    Replies: 42
    Last Post: 7th May 2010, 23:28

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •