User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 2.2 dti starting ok but wont take the throttle straight away

  1. #1
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI

    Trim : FULL LEATHER

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 197,000

    Default 2.2 dti starting ok but wont take the throttle straight away

    it has just started this it will start ok but when i go to rev it nothing , it nearly chokes its self any ideas where to start
    i cleaned the boost sensor and took a quick look at the egr valve dasent look to bad

  2. #2
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Meriva B

    Trim : SE

    Engine : 1.7CDTi

    Year : 2011

    Default

    The amount of Dti starting problems seems to be growing.

    My 1st guesses are dodgy diesel (add some 2 stroke oil to diesel tank might help, and has the Diesel filter been changed?).

    Glow Plugs or Glow Plug relay packed up.

    It can also be the leak off pipes perished (check for leaks or smell of diesel at front of engine), or the one-way valve in the fuel line faulty allowing the diesel to drain back into the tank (park facing downhill, if possible, and see if it helps).

  3. #3
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI

    Trim : FULL LEATHER

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 197,000

    Default

    i might try a fuel filter all the rest have been changed lately and its deffenatley not the diesel , maybe a bbit of water in the filter head . its while smokey when it starts and a bit spluttery
    where is the 1 way valve on the fule line ? do you have a pic

  4. #4
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Meriva B

    Trim : SE

    Engine : 1.7CDTi

    Year : 2011

    Default

    I have not messed about with the one way valve, so I have no information or pic's of it.

    I only mentioned fuel quality in case you are buying fuel that has the red taken out of it, and no, i dont mean you are doing it on purpose, but you never know with small fuel stations.

    Have a look here for more info:
    http://www.uniteddiesel.co.uk/diesel-engine-smoke.php

  5. #5
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI

    Trim : FULL LEATHER

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 197,000

    Default

    thanks for the info Tony thats a good chart the low engine compresion seem to tick my boxes
    i know what you mean about the fuel but i only use good quality stuff same place as 4 years , i was caught out 10 years ago with cheap fuel so once bitten

  6. #6
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Meriva B

    Trim : SE

    Engine : 1.7CDTi

    Year : 2011

    Default

    Glow Plugs also ticks the same boxes.
    Can you use a Multimeter?
    If you can they are easy to check.
    If you have a 12V bulb on 2 bits of wire they can be checked that way too.

  7. #7
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI

    Trim : FULL LEATHER

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 197,000

    Default

    How do i check it with a meter

  8. #8
    Regular Member Signum-Steve's Avatar
    Join Date
    Feb 2009
    Location
    Cramlington Northumberland, V6 Jaguar S-type Sport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar S-Type V6

    Trim : Sport

    Engine : Petrol

    Year : 2003

    Default

    Quote Originally Posted by peadar View Post
    it has just started this it will start ok but when i go to rev it nothing , it nearly chokes its self any ideas where to start
    i cleaned the boost sensor and took a quick look at the egr valve dasent look to bad
    If its starting ok then it won't be glow plugs, leak off pipes fuel filter etc etc. I sounds to me your TPS could be faulty on the Inlet manifold

  9. #9
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Meriva B

    Trim : SE

    Engine : 1.7CDTi

    Year : 2011

    Default

    Even a cheap £5 meter will do, but £20 one's are better quality.

    Do this with the engine cold.

    Remove the caps to the 4 Glow plugs. This is fiddly.
    They are at the back of the engine and look a bit like spark plugs.

    Set the meter to the lowest Ohms range (200?)
    and short the red and black test probes together.
    Make a note of the reading, probably 0.7 or something similar.

    Now put the black meter wire on a clean earth point. A 3rd hand will be useful here.
    Now put the red probe on each of the glow plugs in turn and note the reading.

    A good glow plug should give a reading very similar to shorting the probes together, say 0.7 or 0.8, etc.
    A bad one will not give a reading at all, as it will be open circuit.

    You can also test if any voltage is getting to the glowplugs.
    Set the meter to 20Volts DC or it might have a === symbol.

    Put the black wire on the earth point, and put the red probe inside one of the glow plug caps touching the metal parts inside.
    Using your 4th hand, switch the ignition on but DO NOT start the engine.

    The meter should read about 11.5 to 12.5V until the glow plug light goes off, but it may also still read a voltage even after the glow plug light goes off.

    The glow plugs stay on after the engine has started when the temperature is low.

  10. #10
    Regular Member peadar's Avatar
    Join Date
    Aug 2007
    Location
    in the glens of Antrim N Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI

    Trim : FULL LEATHER

    Engine : 2.2 DTI

    Year : 2003

    Mileage : 197,000

    Default

    Quote Originally Posted by DTI-Steve View Post
    If its starting ok then it won't be glow plugs, leak off pipes fuel filter etc etc. I sounds to me your TPS could be faulty on the Inlet manifold
    silly Q whats TPS ?
    Tony glow plugs tested and are dead on
    wouldnt start 1st go this morning so i took the cover off the back of the EGR valve and it was in the open so i pushed it closed and it started 1st go could this be my problem ?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering wheel not straight, but car drives straight?
    By Danny.surname in forum Suspension, Wheels & Brakes
    Replies: 9
    Last Post: 24th February 2013, 00:21
  2. Replies: 9
    Last Post: 15th January 2013, 14:16
  3. 2.0 DTI Wont start! ( and went it does it cuts straight out)
    By Daz_m in forum Engine & Drivetrain
    Replies: 20
    Last Post: 29th December 2012, 15:11
  4. Broken car....Not atteming starting..throttle postion sensor?
    By smiley-sri in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 13th March 2010, 13:28
  5. Arrrr!Throttle my Throttle Body!
    By boze in forum Engine & Drivetrain
    Replies: 9
    Last Post: 12th September 2009, 11:15

Visitors found this page by searching for:

https:www.vectra-c.comforumshowthread.php152052-2-2-dti-starting-ok-but-wont-take-the-throttle-straight-awaypage2

vectra c 2.2 dti butterfly shut off valve

vectra 2.2 dti not taking throttle cutting out

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •