User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Car has died!!!! Please help

  1. #1
    Regular Member
    Join Date
    May 2008
    Location
    RAMSGATE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Car has died!!!! Please help

    Its the vectra c 2.2 2002 Sri, it has had a bit of a lumpy idle for a while but tonight it died, just won't stay ticking over, it starts up then the revs go up and down then cuts out, have cleaned the TB and intake out, but in the inlet there is oil everywhere? Could it be this or the coil pack?

    Many thanks for any help

  2. #2
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    don't these engines suffer from a dodgy high pressure fuel pump?
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  3. #3
    Regular Member
    Join Date
    Nov 2009
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Caveman_nige View Post
    don't these engines suffer from a dodgy high pressure fuel pump?
    (Assuming its a petrol, I don't know about the diesel 2.2) if its a 2002, its going to be a Z22SE (non-direct) engine which doesn't have a high pressure fuel pump (....If I'm reading the manual correctly).

    Though I'd have thought the fuel pump/filter would be a first point to check, check whether is there is pressure on the fuel rail.

  4. #4
    Regular Member mattv6diesel's Avatar
    Join Date
    Oct 2009
    Location
    portland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Bmw 330d

    Trim : Msport

    Engine : 3.0d

    Year : 2008

    Default

    Chain slip, fuel or might just be a rpm sensor

  5. #5
    Regular Member
    Join Date
    Nov 2009
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by MORGIE8153 View Post
    Its the vectra c 2.2 2002 Sri, it has had a bit of a lumpy idle for a while but tonight it died, just won't stay ticking over, it starts up then the revs go up and down then cuts out, have cleaned the TB and intake out, but in the inlet there is oil everywhere? Could it be this or the coil pack?

    Many thanks for any help
    Also if it was the coil pack, I'd expect it to either not start at all, or to run very badly on three (or less) cylinders! - Had this problem regularly on my old fiesta!!

    Covered in oil could be caused by a few things:
    1. at some point somebody has been topping up the oil and missed (depending on where it is)! - not really a problem, just a waste of oil!
    2. Oil leak somewhere, ie, knackered gasket/seal/head - If its just a gasket or a seal, not too much of a problem, just a case of replacing it (hopefully!), knackered (warped or cracked) head could be a bit more expensive!!

    Has the car been going through oil/coolant a lot recently/has it been burning oil?

  6. #6
    Regular Member
    Join Date
    May 2008
    Location
    RAMSGATE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Think it may be a chain slip, got a bad rattle coming from it too, had the rattle before on start up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cut out and died
    By mabski in forum Engine & Drivetrain
    Replies: 7
    Last Post: 1st March 2011, 10:47
  2. ?Has my Sat Nav died....
    By macdad in forum General Chat
    Replies: 6
    Last Post: 3rd March 2010, 01:49
  3. Help!! everything died!
    By Dai69 in forum Electrical & ICE (including SatNav)
    Replies: 24
    Last Post: 24th February 2010, 15:37
  4. car died on me out of nowhere
    By WKD-mcc in forum Engine & Drivetrain
    Replies: 1
    Last Post: 28th February 2009, 16:03
  5. Car Died!!
    By Silver V in forum Vectra C / Signum Car Chat
    Replies: 32
    Last Post: 2nd July 2007, 10:31

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •