User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: EGR and poor MPG

  1. #1
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default EGR and poor MPG

    Can a Faulty EGR cause poor MPG?

    Im thinking about unplugging it for a few days to see if will sort out my poor MPG problem.Ive tried everything else to cure my problem and the EGR is my last try.

    I know ther is a possabity there could be something wrong with it ebecause the car started smoking when i boot it after the last time i took it apart for a check and clean

    Im in a right dilemma at the moment as im supose to start a new job on monday(been out of work for a bit so its a god send) BUT the rate the car is drinking fuel im going to loose half my weekly wage in diesel so am contemplating actually taking the job

    Please somebody say that it does cause poor MPG lol

    Thankyou

  2. #2
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    A faulty EGR can cause excessive fuel consumption yes, but usually has other symptoms too, like rough idle, lack of power below 2K etc.

    Other than MPG, do you have any other issues?

  3. #3
    Regular Member
    Join Date
    Sep 2011
    Location
    Sipson
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've seen mentioned, but how do you run without the EGR plugged in? when I had a garage clean mine they were so useless they forgot to plug it back in, when I picked up that night it had no power and would not rev over 2500rpm. I pulled over once I had cleared traffic and was back to normal again.

  4. #4
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Quote Originally Posted by krisby View Post
    I've seen mentioned, but how do you run without the EGR plugged in? when I had a garage clean mine they were so useless they forgot to plug it back in, when I picked up that night it had no power and would not rev over 2500rpm. I pulled over once I had cleared traffic and was back to normal again.
    Do you have a 2.2DTi?

    The 1.9CDTi 150 can run without it plugged in.

  5. #5
    Regular Member
    Join Date
    Sep 2011
    Location
    Sipson
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sure do

  6. #6
    Regular Member Bullylad's Avatar
    Join Date
    Feb 2008
    Location
    Bolton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have recently notice a drop in mpg from 45 to around 42 and then the car and spanner light came on for a couple of seconds before going out.
    I immediately assumed it was the EGR valve and a lad at work has the tec 2 thingy and did the diagnostics for me.

    It revealed that it wasn't the EGR but the low pressure boost sensor that was the problem. (this is a small black electrical conector about 5 inches to the left of the EGR valve and is held in place with one star shaped allel screw)

    I took it off and it was covered in a black gungy mess which has obviously biult up over the years. I cleaned it with WD40 and put it back. (10 mins of a job) and it seems to pick up better now.

    Try this on yours and see if it makes any difference?

  7. #7
    Regular Member
    Join Date
    Aug 2011
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Blank the dam EGR off, my saab had no end of problems inc poor economy 36mpg max now its returning 50+MPG on a good run

  8. #8
    Regular Member Bullylad's Avatar
    Join Date
    Feb 2008
    Location
    Bolton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bingo999 View Post
    Blank the dam EGR off, my saab had no end of problems inc poor economy 36mpg max now its returning 50+MPG on a good run


    I'v got to agree with you.

    I'v just ordered a blanking plate for mine and after looking at all the crap that was on the boost sensor you can tell straight away where it has come from.

    Have you had any increase in emissions since blanking it off?

  9. #9
    Regular Member
    Join Date
    Aug 2011
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    nope they have infact gone down, no black smoke any more either

  10. #10
    Regular Member Bullylad's Avatar
    Join Date
    Feb 2008
    Location
    Bolton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just waiting for the postie to arrive then it's done!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What have they done to my poor car?!
    By DNS in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 27th November 2011, 19:55
  2. My poor poor veccy :(
    By tammyman09 in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 9th June 2011, 10:46
  3. Would You Say This Is Poor MPG?
    By Si-SRI in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 7th February 2010, 00:06
  4. Nooooooo!!!!, my poor, poor car!!
    By Duncan in forum Vectra C / Signum Car Chat
    Replies: 208
    Last Post: 11th May 2006, 16:32
  5. My Poor Poor Signum
    By Brake buster in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 30th September 2005, 15:45

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •