User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45

Thread: Aftermarket alternators not suitable for vectra's?

  1. #1
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default Aftermarket alternators not suitable for vectra's?

    Ive just had a chat with a friend of a friend who is a mechanic(ex Vx) and i was bleeting on about my car troubles and explained it was running perfectly before i changed my alternator and he said that some cheap aftermarket ones aren't suitable with Vectra's with full can-bus as they can send funny signals to the ECU and make the car do strange things.

    Now because my car has been doing strange things and i did opt for a cheap replacement alternator(Drivetec from my local autofactors) it would explain alot fo things.

    has anybody else heard this before?

  2. #2
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    its defo worth looking at ...had a 1.9 150 once playing up and it was due to the altonator charge pattern and it beeing a ****e cheap unit ...the injectors take a main feed from the charge feed wire so any incorrect readings would affect the ecu first ....we are talking small deviations here ...but due to the system needs it can miss lead it ......

  3. #3
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Here
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Default

    I have read posts on here before about after market alternators throwing fault codes so maybe your on to something there.

  4. #4
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    well it would explain a hell of alot of problems ive got with my which i never had before i changed my alternator.

    Anymore info/advice would be great

  5. #5
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by justin32 View Post
    well it would explain a hell of alot of problems ive got with my which i never had before i changed my alternator.

    Anymore info/advice would be great
    burn it > ? .....lol ....

  6. #6
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep its true. I had my alternator replaced with an aftermarket one a couple of years ago. About a month after it was fitted the car started showing an error "P0621-01 Generator lamp "L" control circuit malfunction"

    Took it back to the garage and they said the alternator was fine.

    Two years on and I still have the fault code active and still the same alternator!

    It guess my alternator doesn't talk Vectra-C language!

  7. #7
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    Quote Originally Posted by Marky View Post
    Yep its true. I had my alternator replaced with an aftermarket one a couple of years ago. About a month after it was fitted the car started showing an error "P0621-01 Generator lamp "L" control circuit malfunction"

    Took it back to the garage and they said the alternator was fine.

    Two years on and I still have the fault code active and still the same alternator!

    It guess my alternator doesn't talk Vectra-C language!

    Did you suffer from any othr problems apart from the fault code?

    I have no fault code but do have a few issues with the car...mainly electrical

  8. #8
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This is accross the board with lots of vaux cars. Ive seen it on corsas, astras and Zaf's. Because the engine(s) go on so many other models (and in the case of astra H for example the 1.7cdti was fitted to the non can bus astra G) the electronics are not set up right for the full can systems, yet car spares shops list them as the same part number. Some are ok, ive fitted genuine lucas rebuilds from euro car parts which have been fine but if you wanna be 100% sure first time, go for main dealer and put your hand deep into your pocket!

  9. #9
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    Is there any way of finding out if i have the wrong alternator fitted?

    Ive spent so much recently on the car and with xmas fast aproaching i just cnt afford the bill VX would charge(excuse the pun) me.Im pretty sure that the place i got it from would probably give me a refund but id be left with a non running car and have a young family its just not an option.

    I seached more into this and some have said that if it wasnt compatable i would get a fault code come up....(L) something or other? and also im sure i read that some cars have 3 wires for the alternator instead of just the 2 and thats when things can get confusing????

  10. #10
    Regular Member cphaza's Avatar
    Join Date
    Sep 2008
    Location
    Hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    id get a refund and change it for the vaux one. Not to horrific to do yourself. You'll pay a little less than double i think (have a look as the specialist vaux suppliers on ebay for a good price or find someone in vx's trade club near you to save a few quid). What are the other electrical issues you are experiencing?

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. alternators ? urgent help
    By Nessy in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 6th May 2012, 21:45
  2. 3 months and alternators gone
    By coooky in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 10th April 2012, 21:54
  3. Do alternators fail when replacing the battery...??
    By Jconnors in forum Electrical & ICE (including SatNav)
    Replies: 31
    Last Post: 16th October 2010, 21:51
  4. Would this be suitable for my car
    By AlanT1 in forum Diesel Engine related
    Replies: 4
    Last Post: 3rd October 2010, 21:01

Visitors found this page by searching for:

vectra alternator fails after 20 seconds

p0621-01 vauxhall zafira

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •