User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: cant unplug my temp sensor on my thermostat

  1. #1
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default cant unplug my temp sensor on my thermostat

    I tried to unplug the temp sensor on my thermostat today but i cnt figure out how it unplugs.Ive pulled out the yellow clip to unlock it but due ot the location of it i cant see if there is a tab that needs to be pressed or not.Ive tried squeezing it and pulling it apart and also got a screwdriver under it but the damn thing just wont budge.

    The plug is really gunked up so it could be the reason its stuck but dont want to give it some welly incase im doing something wrong.

    The engines a 1.9cdti 150

    Thanks

  2. #2
    New Member
    Join Date
    Nov 2011
    Location
    Lancs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just done mine.

    Pull up the yellow tag and at the bottom where the two little legs were is a bit of a lug push/pull this up with your finger (it's part of the connector) and pull from the top at the same time. It came away quite easily

    I was scratching my head too as it wouldn't shift and I didn't want to break it.

    Hope this helps

  3. #3
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    Thanks mate,
    i changed my stat a few weeks ago and it did come off in the end with a bit of brute force lol.

  4. #4
    Regular Member
    Join Date
    May 2011
    Location
    lancs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    wish i read this before i went out done my head right in was ready to change thermostat oil & coolant change etc and this had me stumped only got the fuel filter done before the heavens opened

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thermostat or temp sensor
    By vectra-man in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 26th June 2013, 08:07
  2. Is it the temp sensor or thermostat 1.9cdti
    By bennettboy in forum Engine & Drivetrain
    Replies: 7
    Last Post: 28th October 2012, 12:45
  3. Z19DT Exhaust Temp Sensor Help... & Thermostat...
    By Vectra Adz in forum Engine & Drivetrain
    Replies: 14
    Last Post: 26th June 2012, 22:08
  4. Thermostat or temp gauge or nothing?
    By mrpoochie01 in forum Vectra C / Signum Troubleshooting
    Replies: 7
    Last Post: 25th March 2012, 12:11
  5. thermostat & temp sensor
    By tommytonguedj in forum Engine & Drivetrain
    Replies: 3
    Last Post: 16th December 2011, 12:37

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •