User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: CDTI 150 Injectors

  1. #1
    Regular Member
    Join Date
    Mar 2007
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CDTI 150 Injectors

    I have read numerous threads about poor starting, with the likely culprits the leak off pipes or injector seals, but can someone shed a bit of light my issue. Basically my local garage undertook a service on my car whilst I was on holiday. When they came to collect the car (only local) they said it took ages to start and then when they changed the oil they drained off a cup of diesel from the oil filter. They suspect it is the injector seals which have gone. Now I had this happen on a Jeep, but it was obvious this was the problem as all the crud was being blown out from the injectors onto the top of the engine. I have read the posts on here and most seem to identify faulty injector seals as there is black crud adjacent the tops of the injectors. Mine are absolutely immaculate and someone has said it sounds more like faulty injectors than just seals. Any ideas??

  2. #2
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As you have said faulty seals show was black crud around the injector.

    it may be worth you taking the car to a diesel injection specialist to test your injectors / clean them / advise on possible fault.

    Must say I have no idea how you would get oil in the fuel filter .......

  3. #3
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    I would get the injectors tested first!, I have been quoted £42 for testing, Just for reference mine chugs on start up & I gave my symptoms over the phone with car details (cdti 150 04rg) & he said it could be seals, faulty injector, bleed back (leaking), or a fractured injector body, so its suck it & see so to speak, but if you get them tested & sorted i would definitely change your oil & filter.

  4. #4
    Regular Member
    Join Date
    Mar 2007
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers guys, I thought it would be a case of testing the injectors first as the problem doesnt quite fit with the other issues people on the forum have had. By the way it was diesel in the oil filter (not oil in the fuel filter). They did change the oil and filter though as part of the service.

  5. #5
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    56 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Is the fuel pump on these lubricated with oil from engines main oil gallery?

    I no some fuel pumps are. So could be a break down in pump :/S

  6. #6
    New Member
    Join Date
    Nov 2010
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi,

    The CDTI150 high pressure fuel pump is lubricated by diesel only. I'm no mech, just a keen DIYer, so can't really give a qualified opinion. I would suspect a fractured injector body as diesel must be getting into the oil filter via the sump e.g. down the cylinders. A injector leak off test would probably be the first step.

    Hope that useful to you.

  7. #7
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Yes i agree you do have fresh oil & filter but the problem still exists, So any use will just start to add derv back into the oil, around £26-30 for a re-change its not worth it.

  8. #8
    Regular Member
    Join Date
    Feb 2011
    Location
    lisburn
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi,could just be the sealing washer on the injector

  9. #9
    Regular Member XPCobra's Avatar
    Join Date
    Dec 2010
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Vectra Hatch

    Trim : SRI with added X-Pack

    Engine : 1.9 16v 150

    Year : 2006

    Mileage : Near 100K

    Default

    needs 4 injectors re-conned or replaced, seen it a few times on this engine, looking at around £400 to get it fixed.

  10. #10
    Regular Member
    Join Date
    Mar 2007
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by XPCobra View Post
    needs 4 injectors re-conned or replaced, seen it a few times on this engine, looking at around £400 to get it fixed.
    cheers for the replies - I think the sealing washer would be too simple and there is no tell tale sign of it blowing fuel out of the top of the injector. Tried a injection specialist near to work and they have quoted £95 per injector to recon. Will take it for a test and see what they say. Out of interest has anyone used any injection specialist in Swindon or Gloucester area (the price was for Halls in Swindon).

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. V6 CDTi Injectors -FIANLLY!!
    By smitd004 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 18th March 2011, 20:07
  2. V6 3.0 CDTI Injectors
    By r.bailey63 in forum Engine & Drivetrain
    Replies: 13
    Last Post: 13th February 2010, 21:36
  3. Injectors x4 1.9 cdti 150
    By mark230678 in forum Parts for sale
    Replies: 0
    Last Post: 30th June 2009, 22:05
  4. 3.0 CDTi Injectors
    By Robbieben in forum Parts for sale
    Replies: 2
    Last Post: 1st February 2008, 23:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •