User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: No Power Steering?? Help

  1. #1
    New Member
    Join Date
    Aug 2011
    Location
    Hull, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy No Power Steering?? Help

    Hi,
    Power steering was working fine today up untill now always been fine but sometimes when going to the car in a morning / starting after been stood for a while the steering would stay stiff for around 30seconds / first turn of the wheel then would work perfect but now its not working at all??

    Any ideas anyone but I dont have to light on the dash
    (no steering wheel light?)

    Thanks in advance

    Regards,
    Smith Online

    P.s my car is a vauxhall vectra 2004 2.0 diesal

  2. #2
    Regular Member
    Join Date
    Aug 2011
    Location
    salisbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by smithonline View Post
    Hi,
    Power steering was working fine today up untill now always been fine but sometimes when going to the car in a morning / starting after been stood for a while the steering would stay stiff for around 30seconds / first turn of the wheel then would work perfect but now its not working at all??

    Any ideas anyone but I dont have to light on the dash
    (no steering wheel light?)

    Thanks in advance

    Regards,
    Smith Online

    P.s my car is a vauxhall vectra 2004 2.0 diesal
    Intrested to see the out come of this my vectra 1.9 cdti accasionly seems to loose power steering for a few seconds usually when driving fast or first thing in the morning

  3. #3
    Regular Member
    Join Date
    Feb 2010
    Location
    Fife
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked the fluid level?

  4. #4
    New Member
    Join Date
    Aug 2011
    Location
    Hull, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy

    Quote Originally Posted by dittohead View Post
    Have you checked the fluid level?
    Yep Checked fluid level on max? (This would show steering wheel light on dash if low?)

    Could it be loose connection in CIM module?

    Regards,
    Smith Online

  5. #5
    Regular Member signumturbo04's Avatar
    Join Date
    Dec 2009
    Location
    SCOTLAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    my car had been doing this for months and finally got to the bottom of it last week, the positive wire coming from the battery to the wee black box on the left hand side of the battery is for PAS only, check both wires are in tact and not fraid as this is what had happened to mine

  6. #6
    New Member melvyn8181's Avatar
    Join Date
    Jul 2011
    Location
    north lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have same car and year as you and mine needed new steering motor/pump.

  7. #7
    New Member
    Join Date
    Aug 2011
    Location
    Hull, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy

    Hi,

    Cars currently getting checked. below is what i have found so far.

    My steering light has started to come on then go off again all the time

    Its not Cim Module
    Its Not Alternater
    Its not low fluid

    Suspect currently is the pump itself. Can anyone tell me if it is coded to the car some people say it is but then i have a garage i know well that says he has done loads of em without codeing And some people online say they fitted a secondhand pump works fine but has steering wheel light on dash all the time since??

    Quote Originally Posted by signumturbo04 View Post
    my car had been doing this for months and finally got to the bottom of it last week, the positive wire coming from the battery to the wee black box on the left hand side of the battery is for PAS only, check both wires are in tact and not fraid as this is what had happened to mine
    Will check this thanks for letting me know

    Regards,
    Smith Online

  8. #8
    New Member melvyn8181's Avatar
    Join Date
    Jul 2011
    Location
    north lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i put new pump on and it wouldnt let me reset fault so constantly have light on dash but steering works fine. proberly needs to go to vx for reset but i aint paying them robbin git £100 to do it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Power steering pump noise? but no steering problems
    By bennettboy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd November 2012, 21:33
  3. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  4. Steering wheel warning light , no power steering!
    By Domchapp in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd July 2012, 22:11
  5. Power Steering Electrical Power Drain
    By AntB in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 1st November 2007, 16:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •