User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: revs sticking at 1000rpm

  1. #1
    Regular Member
    Join Date
    Jul 2011
    Location
    retford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default revs sticking at 1000rpm

    any ideas guys, every now and then the veccy will when coasting or sat sit at 1000rpm and engine makes a revving noise, switch off and it drops to normal again, does this in gear and out of it. not all the time just sometimes

    veccy c 150 cdti btw

    cheers

  2. #2
    Regular Member
    Join Date
    Jul 2011
    Location
    retford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    anyone?

  3. #3
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    Mine done this when alternator was going couple hours later the light came on

  4. #4
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    Could it be the TB butterfly gettin stuck open slightly?

    try getting some carb cleaner and squirting it into the TB(throttle body)

    The only time mine revved that much on idle was when my alternator went kaput but the battery light had already been on for an hour

  5. #5
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI VX-Line Nav

    Engine : 2.0 CDTI [170 PS]

    Year : 2015

    Mileage : 27000

    Default

    Mine does it. Nothing to do with the throttle butterfly as it's always open. Seems normal as it does it on a few members motors. As long as the revs are not:

    - creeping up past the 1,000rpm as if you are gently pressing the accelerator
    - rising/staying after engine switch off.

    Then I would say it's normal.
    Insignia VX-Line Nav CDTI 170.

  6. #6
    Regular Member
    Join Date
    Jul 2011
    Location
    retford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hmmmh, normal?? why does it do it then, never done it on any other car.

  7. #7
    Regular Member
    Join Date
    Jul 2011
    Location
    retford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    back on this now, it went away for a couple of weeks as i had a loose connection on battery positive,,,,

    now its started again. battery connections fine...

    last time i tested the alternator and output was fine..battery output seemed ok aswell. it is now flickering lights on the dash on crank over aswell

    any ideas.battery goosed?

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    32 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Check alt agen mate.

    Also check batt. An check whilst cranking aswel

  9. #9
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    32 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Check alt agen mate.

    Also check batt. An check whilst cranking aswel

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sticking
    By HARRY SRI in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 24th February 2012, 22:23
  2. 1000rpm engine rattle
    By jrh1 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 20th November 2010, 21:53
  3. sticking egr?
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 11th July 2010, 20:01
  4. revs sticking on 1.8vvt 2006
    By tyler in forum Engine & Drivetrain
    Replies: 4
    Last Post: 7th February 2008, 23:53
  5. Replies: 1
    Last Post: 21st January 2008, 23:33

Visitors found this page by searching for:

car sits at 1000 rpm vectra

revs hanging vectra c

corsa c rev stuck at 1000 rpm

revs sitting on 1000 corsa c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •