User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Signum Turbo Fault

  1. #1
    New Member
    Join Date
    Oct 2011
    Location
    S Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Signum Turbo Fault

    Hiya all

    When changing gear, instead of the normall shhhhh noise from my 2003 signum design turbo petrol, im now getting a Sh SH SH noise. Anyone have a clue whats up with it ? Also not getting any boost from the turbo. Not in limp mode or anything, just no thrust as normal. Worried to death the turbos gone?

    Any help greatly appreciated, supposed to be going to Paignton friday in it.

  2. #2
    Regular Member PORKBALLS29's Avatar
    Join Date
    Dec 2008
    Location
    Epping
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I'd start by checking all hoses for splits mate and go from there.

  3. #3
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    As advised go through all you boost pipes especially the one that comes off the back of the turbo and goes under the engine as this is known to come off and does cause these sypmtoms.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  4. #4
    New Member
    Join Date
    Oct 2011
    Location
    S Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks for the tips, Any advise as to where exactly these hoses are ?

  5. #5
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Turbo to intercooler and intercooler to throttle body are the main ones.
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  6. #6
    Regular Member
    Join Date
    Jul 2011
    Location
    peterborough
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    could always be recirc dump valve not closing & allowing any boost build up to be dumped straight away, only a guess as still not solved my probs which every now again struggle with boost in 1st / 2nd gear as seems to drive like a 2 litre,

    car done many miles / modified

  7. #7
    New Member
    Join Date
    Oct 2011
    Location
    S Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    hiya all, thanks for the tips and advise. Are these hoses that may have come off, on the top, bottom, left or right, i know its stupid, but i dont have a clue where they are ?

  8. #8
    Full Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    this is the back of the engine you will see the pipe coming off the back of the turbo circled in red and where it comes out the front (in blue) onto the intercooler which is not in the pic.
    Attachment 48218

    this is the front of the engine.. the big pipe circled comes up from the intercooler to the throttle body. the pipes at the back various vacuum pipes around the turbo, check they are all neither split or slipped off.
    Attachment 48219
    My old Signum, the animal; she now rests in pieces in several other members cars.. https://www.vectra-c.com/forum/garag...vehicle&id=200
    The wifes vec show car, started as a standard daily driver and ended up like this. https://www.vectra-c.com/forum/garag...vehicle&id=709



  9. #9
    New Member
    Join Date
    Oct 2011
    Location
    S Wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Cheers for that, Great pic and explanation, Tho bottom pic i have checked already, Pipes No 12 see ok, The large pipe No7 seems fine also, if a little weakened? maybe its just because of the diameter of it . Will check the Top pic tommorrow.


    Thanks again everyone, great help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fault codes vectra c turbo
    By davedave in forum Petrol Engine related
    Replies: 1
    Last Post: 29th June 2012, 13:22
  2. turbo boost fault 30ltr cdti
    By 30ltr nutter in forum Engine & Drivetrain
    Replies: 2
    Last Post: 10th May 2011, 00:28
  3. 2.0t turbo fault code P0034
    By loonyone in forum Troubleshooting
    Replies: 0
    Last Post: 21st October 2009, 13:04
  4. Bit of help please (Turbo Boost Control Fault)
    By TinFish in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 26th November 2008, 20:06
  5. Help - 2.8 Turbo Elite steering fault?
    By JoolsV6Elite in forum Suspension, Wheels & Brakes
    Replies: 17
    Last Post: 13th October 2008, 20:24

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •