User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Veccy 3.0l v6 cdti problems

  1. #1
    Regular Member SRI_STU's Avatar
    Join Date
    Nov 2009
    Location
    solihull, birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Veccy 3.0l v6 cdti problems

    Ive recently bought a v6 cdti ex plod, i know i know, i shouldn't have

    It runs like a absolute sack of s++t
    It runs lumpy as anything and when driving say 30mph in 3rd or 4th i can feel it juddering. Feels like im going too slow for that gear.
    When i pull up i always leave it running for around 20 sec's b4 i turn it off, but after 10 seconds it makes a click and then runs really bad.
    its a manual version with 78k
    when i give it some welly it goes like stink with no problems at all

    Anyone had any problems with there v6.
    Any help would be much appreciated

  2. #2
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What MY is it?
    Which engine is it, Y30DT or Z30DT?

    Intial diagnosis is it may be a blocked SCV, so what does it rev like at idle?
    If you drive through the revs without changing gear, what is it like?
    As soon as you set a speed on the cruise control, what happens?

    If weather permits, drive at about 40mph with the drivers window down
    What does the turbo sound like?
    Last edited by m8internet; 5th October 2011 at 20:21.

  3. #3
    Regular Member SRI_STU's Avatar
    Join Date
    Nov 2009
    Location
    solihull, birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi mate, its a 2007 07 plate, as for engine im not sure how do i tell.
    On idle it ticks over really lumpy but revs up fine, being police spec it doesn't have cruise. turbo sounds like something off a 800bhp skyline, whistle's its tits off but pulls well.

    cheers

  4. #4
    Regular Member BigWilko's Avatar
    Join Date
    Jan 2010
    Location
    Barnsley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 3.0 CDTI

    Year : 2005

    Default

    I don't think SCV's operate in the low gears. I have a lumpy idle at the moment, i think it's an injector issue.

  5. #5
    Regular Member
    Join Date
    Sep 2011
    Location
    MILTON KEYNES
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by SRI_STU View Post
    Ive recently bought a v6 cdti ex plod, i know i know, i shouldn't have

    It runs like a absolute sack of s++t
    It runs lumpy as anything and when driving say 30mph in 3rd or 4th i can feel it juddering. Feels like im going too slow for that gear.
    When i pull up i always leave it running for around 20 sec's b4 i turn it off, but after 10 seconds it makes a click and then runs really bad.
    its a manual version with 78k
    when i give it some welly it goes like stink with no problems at all

    Anyone had any problems with there v6.
    Any help would be much appreciated
    juddering could be dmf,
    idle could be idle control valve is knackered or excessive injector return - get a garage to do a spill test - dont get charged more than 1 hours labour though!!

  6. #6
    Regular Member omega63's Avatar
    Join Date
    Jul 2010
    Location
    Droylsden, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia 2.0L CDTI SRI hatchback

    Trim : Black leather

    Engine : A20 DTJ 128 HP

    Year : 2009

    Mileage : 126,000

    rolleyes

    Not really sure??? but the loud click you hear maybe the electrically operated EGR valve, as you say it begins to run badly shortly after. Sounds like its a Z30DT, my Vec c is X London Metropolitan Police and when i got it, it was a total s**t tip cosmetically battered. Mechanically it was sound and its been a good car over the 3 years i have had it, just had to change the SCV,s recently and the timing belt, hope you get it sorted, and you get as much fun as i have had with mine..

  7. #7
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As a 2007, it is more likely to be a Z30DT
    This will form part of the start of the engine code, either on the data panel on the drivers door pillar or on the V5

    Idling, what revs is it at?
    If you watch the needle, is it complete steady or does it move?

    It could be the first signs of a blocked SCV, typically starts at higher speeds but if it has been there a long time can affect driving as slow as 20mph in first gear
    Usual sign when the SCV is completely blocked is the turbo continually spooling on, off, on, off, on, off

    It could also be a failed DMF
    On mine I found that with the engine on idle you can feel a very slight vibration through the front seats but disappears once under power
    However, when trying to accelerate there would be extreme hesitance and in some cases loads of revs with no change in speed (ie clutch slip) then suddenly the clutch would apply when the revs had reduced

    Here is what I would do
    Phone or visit three local mechanics
    Ask if they have experience of this car, a Vectra with an Isuzu Z30DT engine
    Demonstrate the issue to them

  8. #8
    Regular Member
    Join Date
    Sep 2010
    Location
    Right here, right now.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI

    Engine : 3.0 V6 CDTI

    Year : 2007

    Default

    I had the same issue, when idling, it would idle fine for 10 seconds, then it would 'click' and then limp mode would kick in.
    The Z30DT performs a Small Quantity Learning check (SQL) to attempt to compensate for worn injectors, this is what was causing my problem, there is a field remedy that a dealer/VX specialist can apply FR2227 I think, this resolved my issue.

  9. #9
    Regular Member
    Join Date
    Mar 2011
    Location
    North Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The problem with my V6 cdti manifested itself when pottering along in a traffic queue or in a parking lot (between tick-over and 1500 rpm). The engine ran lumpy and on some occasions the spanner light comes on and the car goes into get-you-home mode. Stopped, switched off - problem solved until the next time. Goes like the brown stuff off a chrome shovel despite this and diagnosed as sticking (blocked) EGR valve by local main dealer. Hope this helps.

  10. #10
    Regular Member SRI_STU's Avatar
    Join Date
    Nov 2009
    Location
    solihull, birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi all, thanks for all the advice.
    Im not getting any eml but sometimes and only sometimes the turbo stinks of oil ( reminds me of my rs tubo and cossy days)
    Im going down to vauxhall tomorrow to see what they think.
    im hoping its something simply like yours was lee, i will pass the details of what you said on to them. cheers for that
    m8internet, i initially thought it might be dmf related but praying its not.

    I'll let you all know how i get on.

    cheeRS

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice please on my veccy / problems with manifold
    By eraser2002 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 7th June 2010, 07:06
  2. More problems with my Veccy
    By jonnynufc in forum Engine & Drivetrain
    Replies: 68
    Last Post: 9th March 2010, 14:13
  3. Veccy brake problems
    By toughmat in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 2nd June 2009, 16:41
  4. Veccy brake problems
    By toughmat in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 20th May 2009, 19:49
  5. veccy problems
    By Alec in forum Diesel Engine related
    Replies: 3
    Last Post: 2nd March 2008, 14:34

Visitors found this page by searching for:

vectra 3.0 cdti problems

isuzu 3.0 v6 diesel engine problems

vauxhall signum 3.0 v6 cdti common problems

isuzu 3.0 v6 cdti

opel signum 3.0 v6 cdti problems

3.0 cdti problems

any problems with vectra 3.0 diesel

isuzu v6 diesel pulley problems

v6 cdti problems

vauxhall 3.0 v6 diesel engine problems

vauxhall vectra 3.0 v6 cdti sri problems

vectra v6 z30dt cdti problems

vauxhall 3.0 cdti problems on idle

vectra v6 diesel problems

known issues with 3.0 cdti

idle needle jumping 3.0 cdti

3.0l v6 cdti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •