User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Power Steering

  1. #1
    Regular Member M65's Avatar
    Join Date
    Jan 2011
    Location
    Bolton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Power Steering

    The other sections didnt seem to cover steering so I thought Id put this question in here. Apologies if its in the wrong place.

    Anyway, the story goes that the Mrs borrows the car for a couple of days. On her way back home today, the steering goes really heavy. It was fine one turn and the next, she said it was like when you have a puncture and the wheel is stiff to turn. There were no warning lights on the dash and when Ive used the car for the last few weeks, there has also been no warning lights on the dash, no drips under the car, nothing. All has bene well.

    She managed to limp it to an ATS who said there was no power steering fluid in the system and both her and the ATS man saw a puddle on the floor where the car was parked. Im guessing something has snapped, broken etc on the power steering system and dumped the fluid. Ive only just now got a spare minute after getting home from work and putting the little lad to bed but its dark now so Ive not had a chance to look at anything.

    I just wanted to ask if anyone else has had a similar problem and how they fixed it, if anyone has any ideas on what it could be etc. etc. The car is a 2004 CDTi SRi 150.

    Thanks in advance people.

  2. #2
    Regular Member M65's Avatar
    Join Date
    Jan 2011
    Location
    Bolton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Further to this, I topped up the fluid today as per the Haynes manual. Made sure I got the right fluid too by checking at the local stealers. Anyway, put about 0.5L in and then did the lock to lock thing to bleed the system up. I could see a big mist of fluid spraying out as I did so. It did it if I went left or right. Needless to say I stopped.

    I wiped down all the overpsray that I could find in the engine bay and then left it. The Mrs had already spoken to a mechanic friend and its being looked at on Monday at the latest, before then if he can get to our place. However I now have a lovely pool of power steering fluid under my car and dribbling down the road. Awesome! Im guessing at a burst or split pipe, or possibly a broken connection to a pipe somewhere but I really cant see without getting under the car.

    Does this ring any bells with anyone or can anyone with more knowledge than me shed any light on it?

    Thanks in advance people.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Power steering pump noise? but no steering problems
    By bennettboy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd November 2012, 21:33
  3. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  4. Steering wheel warning light , no power steering!
    By Domchapp in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd July 2012, 22:11
  5. Power Steering Electrical Power Drain
    By AntB in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 1st November 2007, 16:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •