User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: SatNav Not working

  1. #1
    Regular Member
    Join Date
    Oct 2009
    Location
    New Marske
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default SatNav Not working

    Vectra C 56 plate 3.0 V6 Elite

    Satnav screen is blank and cannot eject the CD, pressing the Navi button does not work either.

    Radio, Computer and CD work still,

    Any ideas..?

  2. #2
    Regular Member Envy's Avatar
    Join Date
    Jun 2010
    Location
    Welwyn Garden City
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi Nav

    Engine : 1.8 VVT

    Year : 2006

    Mileage : 130k

    Default

    I had this after two days of owning the car.

    The CD got stuck after my 6 year old son decided to continously press the eject button as he found it funny.

    I know this sounds a bit rough but give it a whack on the side of the centre console whilst pressing the eject button. Might have to do this a few times for it to come out.

    Once out (hopefully) then clean it. Then re insert it. All should work fine afterwards if the CD is not too scatched.

    Mine was a right pain to get out but once out, cleaned and put back in, it has behaved itself fine for the last 12 months and still going.

    Hope this helps

    Good luck.
    Last edited by Envy; 19th September 2011 at 23:47.

  3. #3
    Vectra-sport Admin Dre's Avatar
    Join Date
    Dec 2009
    Location
    Vectra-sport Admin
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXD




    Default

    mines done exactly the same i just live without it now as vxl want 1300 for a new cd70 unit

    everything else works apart from the navi its died i know its not the drive as i have tested it and i`ve had the unit to bits as well . Eventually i will probably swap it out for a touch screen

  4. #4
    Regular Member
    Join Date
    Nov 2010
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you ever find out what caused this? Mine ie exactly the same, can't even get the disc out with bashing. It's since I had a flat battery and changed the alternator.

    Please PM me if you can help, thanks.

    Cheers,

    Rog

  5. #5
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what you need is an old bank card and some double sided tape

    put some tape on the end of the card and carefully push it inside keeping the tape as high as possible till its about half way in then let the double sided tape end drop down, then press the eject button whilst pulling slightly on the card your disc should come out attached to the card

    normally its just got stuck on the holder for the disc inside

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CD70 satnav not working
    By davidj387 in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 13th December 2012, 23:44
  2. radio working, not working, working again
    By J P S in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 22nd February 2012, 00:59
  3. Replies: 4
    Last Post: 11th November 2011, 12:05
  4. Replies: 0
    Last Post: 10th November 2011, 22:58
  5. Post codes in CD70 NAVI satnav - who has this working ?
    By eeyore in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 6th October 2011, 16:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •