User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Battery & Spanner Light on.

  1. #1
    Regular Member
    Join Date
    Jul 2010
    Location
    lancs
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Battery & Spanner Light on.

    My battery & spanner light are on. After looking around on the net a test is to put a mutlimeter on the battery when switched off and on.

    So i have done this, got 12.3 when OFF. And 11.6 when engine running.

    Is it the alternator??

  2. #2
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like it

    Irmscher Insignia CDTI 130

    MOD'S...Irmscher front spoiler, Irmscher mats, Irmscher door pins, Irmscher rear spoiler, Irmscher grille, Irmscher skirt & exhausts,Irmscher Roof spoiler MOD'S TO COME..Side skirts,Wheels

  3. #3
    Full Member GazVXLINE170's Avatar
    Join Date
    Jun 2007
    Location
    Scotland
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like th alternator to me. When engine is running the reading should be ~14.3V roughly and ~14.8V when starting up.
    Insignia VX-Line Nav CDTI 170.

  4. #4
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    My alternator went and battery was reading 11.5v on the move. Also the red battery light was on constantly, hence alternator not charging battery, leading to imminent alternator failure.

  5. #5
    Regular Member
    Join Date
    Jul 2010
    Location
    lancs
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok thanks. my batt light is green.

  6. #6
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by ickleric View Post
    ok thanks. my batt light is green.
    I meant the red warning light on the dash

  7. #7
    Regular Member
    Join Date
    Jul 2010
    Location
    lancs
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    better order a new alt then. thanks guys.

  8. #8
    Regular Member
    Join Date
    Sep 2007
    Location
    West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    get it done asap, you motor will be undrivable pretty soon

  9. #9
    Regular Member
    Join Date
    Jul 2010
    Location
    lancs
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Prob going to swap myself. Read the Haynes manual and it says to drain the radiator fluid. Anyone know why?? Is it just cos something is in the way??

    I have a 2.2 Petrol Vectra C SRI.

  10. #10
    Regular Member goosey_1976's Avatar
    Join Date
    Nov 2009
    Location
    Dunston, Gateshead
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    its definately the alternator, and it gets hard to steer in the fast lane when it decides to die on you. The RAC bloke who came to collect me restarted the car and said give it about three minutes then the alternator light with come on followed by the car/spanner light and the engine will rev up to 1000rpm and stay there before cutting out.

    mine read 11.2volts Lee

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. spanner and battery light on
    By honyin in forum Troubleshooting
    Replies: 9
    Last Post: 8th July 2012, 17:38
  2. battery light on along with spanner through car light
    By conny in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 24th May 2011, 13:45
  3. Battery light and car with spanner icon?
    By johnnyallen in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 22nd June 2010, 10:29
  4. Help..Clear spanner light by disconnecting battery?
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 23rd April 2010, 13:01
  5. Spanner light after changing battery
    By gtr1000 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 10th December 2008, 21:40

Visitors found this page by searching for:

battery light on now spanner

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •