User Tag List

Thanks Thanks:  0
Likes Likes:  0

View Poll Results: What mileage range did your alternator fail

Voters
189. You may not vote on this poll
  • 20,000 to 30,000

    7 3.70%
  • 30,001 to 40,000

    14 7.41%
  • 40,001 to 50,000

    17 8.99%
  • 50,001 to 60,000

    25 13.23%
  • 60,000 +

    85 44.97%
  • My alternator has been tickety boo!!

    41 21.69%
Page 1 of 8 123 ... LastLast
Results 1 to 10 of 80

Thread: Alternator failure @ what mileage?

  1. #1
    Regular Member Geo77's Avatar
    Join Date
    Sep 2009
    Location
    North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Exclamation Alternator failure @ what mileage?

    My alternator went 7 weeks out of warranty!!!!

    Stealers got 70% out of Vauxhall UK but my bill was still £270!!

    Genuine GM alternator was £599.00 +VAT!!!!

    As this is a fault with plenty of instances I am currently in correspondance with Glews Vauxhall (where I bought the car) to get the remaining 30% paid by them! I am using the sale of goods act - a reasonable expectation that goods should last etc.

    I am not tight, but the fact that these alternators are so poor means that there is a principle to uphold here!

    PLease vote at what mileage range your alternator failed.

    Thanks!

  2. #2
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine went somewhere between 80k and 90k I think. Bought one of fleabay for about £100, been fine since although I know others have had issues with non-genuine alternators. Others have also found a specific component within the alternator that could be repaired and the alternator worked again (can't remember what)

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    The one on my missus' car (CDTi 150) lasted 126,000 miles

  4. #4
    Regular Member john_k_sri's Avatar
    Join Date
    Oct 2006
    Location
    Waterloo, Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRI NAV XP

    Engine : 1.9 CDTI 150

    Year : 2007

    Mileage : 72K

    Default

    Mine went without warning at approx 52K (CDTI 150). Common problem on the CDTI's.

  5. #5
    Regular Member Grimo72's Avatar
    Join Date
    Apr 2008
    Location
    Lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by john_k_sri View Post
    Mine went without warning at approx 52K (CDTI 150). Common problem on the CDTI's.

    ditto 60k just died .............

  6. #6
    Regular Member
    Join Date
    Dec 2006
    Location
    Rugby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Angry

    53K for me, totally dead one morning. Cost £400 to get it fixed.

  7. #7
    Regular Member LJ sxi-nav's Avatar
    Join Date
    Apr 2007
    Location
    Winchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Knox View Post
    Mine went somewhere between 80k and 90k I think. Bought one of fleabay for about £100, been fine since although I know others have had issues with non-genuine alternators. Others have also found a specific component within the alternator that could be repaired and the alternator worked again (can't remember what)
    Ditto

  8. #8
    Regular Member
    Join Date
    Jun 2006
    Location
    St. Helens,Merseyside
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    iv voted 60+
    the alt was changed by the last owner a few weeks before i got the car (approx 62k)
    and its a 2005 CDTI150

  9. #9
    Regular Member
    Join Date
    Jun 2010
    Location
    north east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine just died over night at about 32000 miles. Never in my motoring life have I known a alternator die so early on, if it has 100 000 on it then fine but it didnt.

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    I'm on 80k and everything works as it should.

Page 1 of 8 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. suspected alternator failure
    By redross555 in forum Electrical & ICE (including SatNav)
    Replies: 22
    Last Post: 9th January 2013, 00:36
  2. alternator failure
    By hippo in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 21st July 2011, 21:44
  3. Alternator failure??
    By Lowick in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 3rd September 2010, 13:32
  4. Alternator Failure
    By Eddie Dee in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 22nd March 2010, 23:40
  5. Alternator failure, but shall I replace battery too?
    By ishaqmir in forum Engine & Drivetrain
    Replies: 7
    Last Post: 11th February 2010, 16:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •